Bug 1292175 - User needs ability to change user and group owner of already run report
User needs ability to change user and group owner of already run report
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: Gregg Tanzillo
Dave Johnson
report:rbac
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 11:11 EST by Ian Tewksbury
Modified: 2017-08-21 09:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 09:03:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Tewksbury 2015-12-16 11:11:48 EST
Description of problem:

Currently any reports that are run are own by the user and the group that user is logged in as. After the report is run there is no way to change that owner. For example with a VM if an admin user creates a VM they can re-assign the owner to another group if needed. This functionality is missing for reports. This becomes a problem when there are groups who can only see resources their group owns. So if an admin user creates a report there is no way for them to then share that report with more limited users excpet for downloading and emailing. There should be the ability for the owning user/group of a run report to be able to change the owner.


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. log in as a user in the super admin group
2. generate a report
3. log in as a user not in the super admin group with limited visibility
4. the limited user can not see the report
5. the admin user has no way to make the report visible to the limited user

Actual results:

There is now way for the admin user to make reports they generate visible to more limited users after the fact.


Expected results:

Need a mechanism to change the owner on already generated reports.


Additional info:

This is an issue encountered with a client.
Comment 4 Chris Pelland 2017-08-21 09:03:51 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.
Comment 5 Ian Tewksbury 2017-08-21 09:07:27 EDT
@chris,

This is still definitely an issue. I am unclear why it is being closed just because Engineering hasn't prioritized it yet. It seems strange to put the onus back on me to create the bug just because management hasn't schedule this work yet.

Note You need to log in before you can comment on or make changes to this bug.