Bug 1292179 - Backport: Separate rbac calculation from _make_network_dict
Backport: Separate rbac calculation from _make_network_dict
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Haim Daniel
Eran Kuris
: Triaged
Depends On:
Blocks: 1290562
  Show dependency treegraph
 
Reported: 2015-12-16 11:36 EST by Haim Daniel
Modified: 2016-04-26 09:32 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-neutron-7.0.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:19:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 258346 None None None 2015-12-16 11:36 EST

  None (edit)
Description Haim Daniel 2015-12-16 11:36:29 EST
When a subnet dict was being created, it was calling
_make_network_dict to get the 'shared' flag for the
subnet. The issue with this is that the _make_network_dict
function would iterate over the subnets on the passed in
network object, which would trigger a database lookup
of all of the subnets.
This patch just separates the 'shared' flag calculation out
into a separate function that both calls can leverage.
Comment 4 Eran Kuris 2016-01-21 10:59:15 EST
verified : 
https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/rhos-unittest-gerrit-neutron-rhel-7.2/721/testReport/


(Tempest_run)[stack@instack neutron]$ rpm -qa |grep neutron 
openstack-neutron-common-7.0.1-6.el7ost.noarch
openstack-neutron-7.0.1-6.el7ost.noarch
python-neutron-7.0.1-6.el7ost.noarch
openstack-neutron-ml2-7.0.1-6.el7ost.noarch
openstack-neutron-openvswitch-7.0.1-6.el7ost.noarch
python-neutronclient-3.1.0-1.el7ost.noarch
Comment 5 errata-xmlrpc 2016-04-07 17:19:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.