Bug 1292214 - HE deploy on NFS failed with sanlock error
HE deploy on NFS failed with sanlock error
Status: CLOSED NOTABUG
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General (Show other bugs)
1.2.6.1
x86_64 Linux
unspecified Severity urgent (vote)
: ---
: ---
Assigned To: Sandro Bonazzola
Ilanit Stein
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 13:22 EST by Artyom
Modified: 2015-12-16 13:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 13:57:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
alukiano: planning_ack?
alukiano: devel_ack?
alukiano: testing_ack?


Attachments (Terms of Use)
setup, vdsm and sanlock logs (81.66 KB, application/zip)
2015-12-16 13:22 EST, Artyom
no flags Details

  None (edit)
Description Artyom 2015-12-16 13:22:57 EST
Created attachment 1106502 [details]
setup, vdsm and sanlock logs

Description of problem:
HE deploy failed with sanlock error
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/sanlock/lockspace.py", line 229, in _misc
    offset=offset
SanlockException: (19, 'Sanlock lockspace write failure', 'No such device')
2015-12-16 20:16:27 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Misc configuration': (19, 'Sanlock lockspace write failure', 'No such device')


Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.2.6.1-1.el7ev.noarch
vdsm-4.16.31-1.el7ev.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run hosted-engine --deploy
2. Choose deploy on NFS and continue deployment
3.

Actual results:
Deployment failed
[ INFO  ] Connecting Storage Pool
[ INFO  ] Verifying sanlock lockspace initialization
[ ERROR ] Failed to execute stage 'Misc configuration': (19, 'Sanlock lockspace write failure', 'No such device')
[ INFO  ] Stage: Clean up


Expected results:
Deployment succeed without any errors

Additional info:
Comment 1 Artyom 2015-12-16 13:42:31 EST
Looks like problem in selinux, # setenforce 0 solve problem
selinux-policy-targeted-3.13.1-23.el7.noarch
selinux-policy-3.13.1-23.el7.noarch
Dec 16 20:38:37 alma07 kernel: type=1400 audit(1450291117.396:42): avc:  denied  { read } for  pid=667 comm="sanlock" name="8c39aace-dcad-4ca3-a2fe-e0d47351fa5f" dev="tmpfs" ino=102783 scontext=system_u:system_r:sanlock_t:s0-s0:c0.c1023 tcontext=system_u:object_r:virt_var_run_t:s0 tclass=lnk_file
Comment 2 Artyom 2015-12-16 13:57:46 EST
My mistake host had after reprovision old packages, after update all host packages deployment works fine.

Note You need to log in before you can comment on or make changes to this bug.