Bug 129224 - ldapadd does not support referrals
ldapadd does not support referrals
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openldap (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 08:09 EDT by Florian Brand
Modified: 2015-01-07 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:21:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Florian Brand 2004-08-05 08:09:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I have set up Openldap in a Master Slave scenario.
While trying to add an entry on the slave with ldapadd with a simple
bind I get the error-message. "Insufficient access to parent"
We have reseached the problem a bit. What happens.
ldapadd connects and authenticates to the slave.
When it sends the ldif it gets the referral to the master.
Then ldap add connects to the master and resends the ldif to the master.
The master then gives the erromessage, because ldapadd forgot to
authenticate. 

pam_ldap can change passwords on via the slave, so the problem is
definetely on ldapadd

Version-Release number of selected component (if applicable):
openldap-2.0.27

How reproducible:
Always

Steps to Reproduce:
1. Configure Master/Slave ldap 
2. ldapadd -f test.ldif -D <CN> -W [-x -C -v -d3] 
   [] options for debug messages, which show the described behaviour
    

Actual Results:  entry was not created

Expected Results:  entry is added

Additional info:

performing the command on the master works nicely.
Master/Slave have the identical configuration apart from the
master/slave specific bit.
Problem was verified on a different machine.
Comment 1 RHEL Product and Program Management 2007-10-19 15:21:20 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.