Bug 1292244 - Update python-statsd to 3.2.1
Update python-statsd to 3.2.1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-statsd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tristan Cacqueray
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 14:57 EST by Paul Belanger
Modified: 2015-12-19 18:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-18 23:34:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Belanger 2015-12-16 14:57:15 EST
Spec URL: https://pabelanger.fedorapeople.org/python-statsd/2015-12-16-0001/python-statsd.spec
SRPM URL: https://pabelanger.fedorapeople.org/python-statsd/2015-12-16-0001/python-statsd-3.2.1-1.fc24.src.rpm
Description: I've upgraded statsd to the latest version and reworked the package to support both python2 and python3
Fedora Account System Username: pabelanger
COPR: https://copr.fedoraproject.org/coprs/pabelanger/python-statsd/build/148259/
Comment 2 Zbigniew Jędrzejewski-Szmek 2015-12-16 22:06:21 EST
No need to define %sum: just put the summary in the first Summary field, and then refer to it with %{summary}.

Why do you need to remove the docs dir? Doing %doc docs/_build_/html should work just as well and is more standard and simpler.

BR: python3-sphinx seems unnecessary.

--

Have you done any reviews (apart from python-shade)? Could you please do two or three from http://fedoraproject.org/PackageReviewStatus/NEW.html and post the links here.
Comment 4 Paul Belanger 2015-12-17 14:15:35 EST
Took some time today to also review some NEW issues:

https://bugzilla.redhat.com/show_bug.cgi?id=1292209
https://bugzilla.redhat.com/show_bug.cgi?id=1291061
https://bugzilla.redhat.com/show_bug.cgi?id=1289970
https://bugzilla.redhat.com/show_bug.cgi?id=1286867
https://bugzilla.redhat.com/show_bug.cgi?id=1283327
https://bugzilla.redhat.com/show_bug.cgi?id=1279104
https://bugzilla.redhat.com/show_bug.cgi?id=1268083

I'm sure I didn't get the workflow down properly to triage the issue, but comments we left none the less.  Did get to spend some time using 'fedora-review', neat little tool.
Comment 5 Zbigniew Jędrzejewski-Szmek 2015-12-18 13:38:50 EST
First, a comment on your reviews:

- you seem to put too much trust in automated tools. Actually that's the hard part of doing review, knowing when to ignore ignore rpmlint or fedora-review warnings, and when not to. Disillusionment comes with more experience ;)

- If rpmlint or another tool flags some error, the reviewer shouldn't just paste the message, they should discuss the underlying issue, unless it's obvious. E.g. in https://bugzilla.redhat.com/show_bug.cgi?id=1268083#c2 rpmlint says noarch-python-in-64bit-path. The reason could be that %{python2_sitelib} should be used instead of %{python2_sitearch}, or that the package should not be noarch. The reviewer should, as far as they are able to, hint at a solution.

- also, fedora-review leaves various check boxes empty, the review is supposed to fill those in manually.

But the majority of you comments are very useful (good catch with the license in #1268083), and you seem to know how everything is supposed to work. I'm happy to add you to the packagers group.
Comment 6 Paul Belanger 2015-12-18 14:00:13 EST
Thanks for the sponsor!

Ya, I just used fedora-review for the first time yesterday. For the most part, I manually review the spec, make notes, then run the automation.  I agree, some of the things it outputs aren't valid.  But time will help me learn the ins and outs.

I'll likely be asking for more help with reviews in the future, and hope to follow along with fedora-devel.
Comment 7 Zbigniew Jędrzejewski-Szmek 2015-12-18 14:21:58 EST
The spec change in comment #3 looks reasonable.

It failed to build for me in rawhide root, looks like another fallout from nsswitch changes (#1284323). Unfortunately the solution to that has stalled on some upstream changes, so you might need to provide a workaround or simply disable that test.

I think the next step would be for Triastan to accept your acl requests.


(In reply to Paul Belanger from comment #6)
> I'll likely be asking for more help with reviews in the future, and hope to
> follow along with fedora-devel.
Yes, please do that. I'm also happy to answer any questions and provide help. I'm 'zbyszek' in #fedora-devel on freenode.org.
Comment 8 Paul Belanger 2015-12-18 14:54:34 EST
Will do, thanks.

Tristan has already accepted my request.  See you in IRC!
Comment 9 Paul Belanger 2015-12-18 23:34:40 EST
I've upgrade the spec on pkgdb.

Note You need to log in before you can comment on or make changes to this bug.