Bug 1292245 - daemon crashes with traceback after resume from suspend-to-disk
daemon crashes with traceback after resume from suspend-to-disk
Status: CLOSED ERRATA
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 14:58 EST by Brian Brock
Modified: 2016-02-16 04:32 EST (History)
2 users (show)

See Also:
Fixed In Version: redhat-certification-2.1-20151217
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 04:32:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Brock 2015-12-16 14:58:53 EST
Description of problem:
The redhat-certification daemon crashed after the system resumed from a suspend-to-disk test.


Version-Release number of selected component (if applicable):
redhat-certification-2.1-20151216.1.el7.noarch
redhat-certification-hardware-1.7.1-20151215.el7.noarch


How reproducible:
no yet reproduced

Steps to Reproduce:
1. Create a new hardware certification on a laptop system
2. start any test, triggering the mandatory suspend tests
3. go through all 4 suspend tests
4. check the daemon status after the 4th resume

Actual results:
Listener but not daemon running.  Traceback in /var/log/rhcert/RedHatCertDaemon.log

Tests that were scheduled by the user are never run.

Expected results:
Daemon continues to run without error, testing continues

Additional info:
Subtest FunctionKey-disk:
This test will suspend the operating system.
Please resume by pressing the power button after suspend has completed.
response: True
response: True
response: True
Verified suspend
Verified resume from disk
PASS
Traceback (most recent call last):
  File "/usr/bin/rhcert-backend", line 37, in <module>
    success = rhcertBackend.do(args)
  File "/usr/lib/python2.7/site-packages/rhcert/client/backend.py", line 179, in do
    return self.doServer(args)
  File "/usr/lib/python2.7/site-packages/rhcert/client/backend.py", line 212, in doServer
    return daemon.run()
  File "/usr/lib/python2.7/site-packages/rhcert/listener/daemon.py", line 77, in run
    self.runXML(job)
  File "/usr/lib/python2.7/site-packages/rhcert/listener/daemon.py", line 95, in runXML
    return self.runPlan()
  File "/usr/lib/python2.7/site-packages/rhcert/listener/daemon.py", line 138, in runPlan
    harness.run(self.resultsDocument)
  File "/usr/lib/python2.7/site-packages/rhcert/client/harness.py", line 490, in run
    return self._doRun(testDocuments)
  File "/usr/lib/python2.7/site-packages/rhcert/client/harness.py", line 573, in _doRun
    returnValue = self.runTest(logDirectory, testDocument, runDocument, outputFilePath)
  File "/usr/lib/python2.7/site-packages/rhcert/client/harness.py", line 1010, in runTest
    if not test.finish(self.planner, runDocument):
  File "/usr/lib/python2.7/site-packages/rhcert/suites/hwcert/hwcert/hardwareTest.py", line 130, in finish
    runDocument.appendDevices(devices)
  File "/usr/lib/python2.7/site-packages/rhcert/documentbase.py", line 209, in appendDevices
    self.appendDevice(device)
  File "/usr/lib/python2.7/site-packages/rhcert/documentbase.py", line 192, in appendDevice
    self.setAttribute(deviceElement, Attributes.vendor, device.getVendor())
AttributeError: UdevDevice instance has no attribute 'getVendor'
Comment 2 Brian Brock 2015-12-16 15:05:23 EST
testing resumes after the daemon is started, and executes the test which the user selected (hwcert/video, in this case).
Comment 3 Brian Brock 2015-12-16 15:20:13 EST
I'm encountering this on other systems, whenever the mandatory suspend test is reached.
Comment 4 Brian Brock 2015-12-16 16:09:29 EST
Queued up several tests (all of fv_*), and have to restart the daemon after each test case is run (same crash / traceback).
Comment 7 Brian Brock 2016-01-06 15:13:02 EST
I have not seen this in recent packages when running all of the 'suspend' tests on a laptop.

verified in:
redhat-certification-2.1-20151221.el7.noarch
redhat-certification-hardware-1.7.1-20151218.el7.noarch
Comment 9 errata-xmlrpc 2016-02-16 04:32:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0196.html

Note You need to log in before you can comment on or make changes to this bug.