This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1292255 - geeqie shows in the EXIF embedded image instead of the contents of a RAW file.
geeqie shows in the EXIF embedded image instead of the contents of a RAW file.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: geeqie (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthew Miller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 15:36 EST by vl
Modified: 2016-02-27 16:43 EST (History)
5 users (show)

See Also:
Fixed In Version: geeqie-1.2.2-3.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-27 16:43:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm -qa (94.04 KB, text/plain)
2015-12-16 15:36 EST, vl
no flags Details
debug.4 (40.29 KB, text/plain)
2015-12-16 15:39 EST, vl
no flags Details
screenshot (83.76 KB, image/png)
2015-12-16 15:46 EST, vl
no flags Details
Patch for raw files (1.72 KB, patch)
2016-02-20 17:52 EST, Zygmunt Zarzecki
no flags Details | Diff

  None (edit)
Description vl 2015-12-16 15:36:03 EST
Created attachment 1106517 [details]
rpm -qa

Description of problem:

geeqie  shows in the EXIF embedded image instead of the contents of a RAW file. 


$ LANG=en_US geeqie -v
Geeqie 1.2.1

How reproducible:

reproduced as a problem in the new installation of the system and the system which was upgraded from F22 to F23. The F22 version is not a problem.
The problem is reproduced on RAW files Nikon (D90 D7100) and Canon 7D.
jpg, PNG, and other file types are displayed normally.


Additional info:

LANG=en_US geeqie --debug=1

debugging output enabled (level 1)
    0.000817 (+00000.000817) main: gtk_init
    0.022676 (+00000.021859) main: pixbuf_inline_register_stock_icons
    0.023186 (+00000.000510) main: setting default options before commandline handling
    0.023252 (+00000.000066) main: parse_command_line
    0.023306 (+00000.000054) main: mkdir_if_not_exists
    0.023930 (+00000.000624) main: load_options
loader reported [GdkPixdata] [GdkPixdata] [.gdkp]
loader reported [png] [PNG] [.png]
loader reported [qtif] [QuickTime] [.qtif;.qif]
loader reported [ani] [Windows animated cursor] [.ani]
loader reported [jpeg2000] [JPEG 2000] [.jp2;.jpc;.jpx;.j2k;.jpf]
loader reported [icns] [MacOS X icon] [.icns]
loader reported [svg] [Scalable Vector Graphics] [.svg;.svgz;.svg.gz]
loader reported [tga] [Targa] [.tga;.targa]
loader reported [wmf] [Windows Metafile] [.wmf;.apm]
Skipped 'Digital camera RAW' from loader
loader reported [xpm] [XPM] [.xpm]
loader reported [pnm] [PNM/PBM/PGM/PPM] [.pnm;.pbm;.pgm;.ppm]
loader reported [jpeg] [JPEG] [.jpeg;.jpe;.jpg]
loader reported [tiff] [TIFF] [.tiff;.tif]
loader reported [bmp] [BMP] [.bmp]
loader reported [xbm] [XBM] [.xbm]
loader reported [gif] [GIF] [.gif]
loader reported [ico] [Windows icon] [.ico;.cur]
    0.026816 (+00000.002886) layout_new: start
Initializing LIRC... failed
    0.034527 (+00000.007711) layout_actions_setup: start
    0.055181 (+00000.020654) layout_actions_setup: add menu
    0.055769 (+00000.000588) layout_actions_setup: add toolbar
    0.055868 (+00000.000099) layout_actions_setup: marks
    0.058148 (+00000.002280) layout_actions_setup: editors
    0.058278 (+00000.000130) layout_actions_setup: status_update_write
    0.058334 (+00000.000056) layout_actions_setup: actions_add_window
    0.058383 (+00000.000049) layout_actions_setup: end
Setting stereo mode 0000 for imd 0x55ab0a7fbca0
update size: 0x55ab0a7ff9a0  0 0   0 0
col tab pop cols=1 rows=0
    0.150286 (+00000.091903) pixbuf renderer updated - started drawing 0x55ab0a8020b0, img: 200x70
    0.150394 (+00000.000108) pixbuf renderer updated - started drawing 0x55ab0a8020b0, img: 200x70
    0.150435 (+00000.000041) pixbuf renderer updated - started drawing 0x55ab0a8020b0, img: 200x70
update size: 0x55ab0a7ff9a0  0 0   610 114
    0.184151 (+00000.033716) pixbuf renderer updated - started drawing 0x55ab0a8020b0, img: 200x70
    0.198682 (+00000.014531) layout_new: end
Register realtime 0 /tmp
Too frequent update of /
    0.316771 (+00000.118089) init_exif_time_data: ...
new image loader 0x55ab0a99d240, bufsize=4096 idle_loop=1
exif read /tmp/DSC_3798.NEF, sidecar: -
Thread pool num threads: 1
    0.330656 (+00000.013885) image reset
    0.330767 (+00000.000111) image begin
new image loader 0x55ab0a99d360, bufsize=4096 idle_loop=1
Thread pool num threads: 2
Register realtime 0 /tmp/DSC_3798.NEF
    0.332260 (+00000.001493) read ahead cancelled for :null
added Xmp.dc.subject /tmp/DSC_3798.NEF

Loading options from /home/lv77/.config/geeqie/geeqierc.xml ... done
    0.380840 (+00000.048580) layout_editors_reload_start
    0.380973 (+00000.000133) main: gtk_main
image_load_size_cb: 160x120
    0.381494 (+00000.000521) pixbuf renderer updated - started drawing 0x55ab0a8020b0, img: 160x120
    0.381557 (+00000.000063) pixbuf renderer updated - started drawing 0x55ab0a8020b0, img: 160x120
image activate focus_in 0
update size: 0x55ab0a7ff9a0  0 0   610 750
    0.415528 (+00000.033971) pixbuf renderer updated - started drawing 0x55ab0a8020b0, img: 160x120
freeing image loader 0x55ab0a99d240 bytes_read=11641490
new image loader 0x55ab0a99dea0, bufsize=4096 idle_loop=1
Thread pool num threads: 2
col tab pop cols=8 rows=1
    0.456202 (+00000.040674) image load completed "/tmp/DSC_3798.NEF" (current)
    0.456291 (+00000.000089) pixbuf renderer done 0x55ab0a8020b0
    0.457077 (+00000.000786) image done
Notify pane_histogram: /tmp/DSC_3798.NEF 0004
freeing image loader 0x55ab0a99d360 bytes_read=11641490
    0.457769 (+00000.000692) layout_editors_reload_idle_cb: get_desktop_files
Couldn't load icon /opt/XnConvert/xnconvert.png: Icon '/opt/XnConvert/xnconvert.png' not present in theme
Couldn't load icon /opt/XnConvert/xnconvert: Icon '/opt/XnConvert/xnconvert' not present in theme
    0.541012 (+00000.083243) layout_editors_reload_idle_cb: setup_editors
    0.541978 (+00000.000966) layout_editors_reload_idle_cb: setup_editors done
thumb done: /tmp/DSC_3798.NEF
thumb progress: 1 of 1
freeing image loader 0x55ab0a99dea0 bytes_read=11641490
collection manager flushing
collection manager is up to date
Unregister realtime 1 /tmp/DSC_3798.NEF
    3.851291 (+00003.309313) image reset
    3.851386 (+00000.000095) read ahead cancelled for :null

==================================
Comment 1 vl 2015-12-16 15:39 EST
Created attachment 1106518 [details]
debug.4
Comment 2 vl 2015-12-16 15:46 EST
Created attachment 1106519 [details]
screenshot
Comment 3 Matthew Miller 2015-12-17 08:15:11 EST
Hmmm; interesting that this is a regression. Do you see the same problem with the exiv2 command-line tool?
Comment 4 vl 2015-12-17 14:09:02 EST
(In reply to Matthew Miller from comment #3)
> Hmmm; interesting that this is a regression. Do you see the same problem
> with the exiv2 command-line tool?

$ LANG=us_EN exiv2 /tmp/D7100.NEF 
File name       : /tmp/D7100.NEF
File size       : 22291983 Bytes
MIME type       : image/x-nikon-nef
Image size      : 6036 x 4020
Camera make     : NIKON CORPORATION
Camera model    : NIKON D7100
Image timestamp : 2015:11:11 20:27:34
Image number    : 
Exposure time   : 1/160 s
Aperture        : F4
Exposure bias   : 0 EV
Flash           : Yes, compulsory, return light not detected
Flash bias      : 
Focal length    : 85.0 mm (35 mm equivalent: 127.0 mm)
Subject distance: 
ISO speed       : 200
Exposure mode   : Manual
Metering mode   : Spot
Macro mode      : 
Image quality   : RAW    
Exif Resolution : 160 x 120
White balance   : AUTO1       
Thumbnail       : None

right?
Comment 5 Michael Schwendt 2015-12-17 15:37:05 EST
> the system which was upgraded from F22 to F23.
> The F22 version is not a problem.

Geeqie between F22 and F23 hasn't changed recently. F22 was released with Geeqie 1.2, and the small patch to 1.2.1 is unrelated.

exiv2 in F23 is newer than in F22, however.
Comment 6 Michael Schwendt 2015-12-17 16:51:50 EST
eog (Eye of GNOME image viewer) is also affected.
Comment 7 vl 2016-01-17 05:18:07 EST

exiv2-0.24-4.fc22.x86_64.rpm
exiv2-libs-0.24-4.fc22.x86_64.rpm
geeqie-1.2-0.1.20141130gita1afabd.fc22.x86_64.rpm 

F22 not affected
Comment 8 Zygmunt Zarzecki 2016-02-20 13:49:07 EST
I have the same problem in geekie (geeqie-1.2-0.6.20150812git2b87884.fc23.x86_64) with RAW files.

[zyga@futsu ~]$ LANG=en_US geeqie --debug=1
debugging output enabled (level 1)
    0.001847 (+00000.001847) main: gtk_init
    0.024176 (+00000.022329) main: pixbuf_inline_register_stock_icons
    0.024436 (+00000.000260) main: setting default options before commandline handling
    0.024487 (+00000.000051) main: parse_command_line
    0.024543 (+00000.000056) main: mkdir_if_not_exists
    0.025514 (+00000.000971) main: load_options
loader reported [GdkPixdata] [GdkPixdata] [.gdkp]
loader reported [png] [PNG] [.png]
loader reported [qtif] [QuickTime] [.qtif;.qif]
loader reported [jpeg2000] [JPEG 2000] [.jp2;.jpc;.jpx;.j2k;.jpf]
loader reported [tga] [Targa] [.tga;.targa]
loader reported [gif] [GIF] [.gif]
loader reported [xpm] [XPM] [.xpm]
loader reported [svg] [Scalable Vector Graphics] [.svg;.svgz;.svg.gz]
loader reported [ani] [Windows animated cursor] [.ani]
loader reported [wmf] [Windows Metafile] [.wmf;.apm]
loader reported [pnm] [PNM/PBM/PGM/PPM] [.pnm;.pbm;.pgm;.ppm]
loader reported [tiff] [TIFF] [.tiff;.tif]
loader reported [jpeg] [JPEG] [.jpeg;.jpe;.jpg]
loader reported [bmp] [BMP] [.bmp]
loader reported [ico] [Windows icon] [.ico;.cur]
loader reported [icns] [MacOS X icon] [.icns]
loader reported [xbm] [XBM] [.xbm]
    0.028204 (+00000.002690) layout_new: start
Initializing LIRC... failed
    0.028534 (+00000.000330) layout_actions_setup: start
    0.042715 (+00000.014181) layout_actions_setup: add menu
    0.043048 (+00000.000333) layout_actions_setup: add toolbar
    0.043100 (+00000.000052) layout_actions_setup: marks
    0.045078 (+00000.001978) layout_actions_setup: editors
    0.045170 (+00000.000092) layout_actions_setup: status_update_write
    0.045209 (+00000.000039) layout_actions_setup: actions_add_window
    0.045244 (+00000.000035) layout_actions_setup: end
Setting stereo mode 0000 for imd 0x55f9e184d130
update size: 0x55f9e17e2bd0  0 0   0 0
    0.118643 (+00000.073399) pixbuf renderer updated - started drawing 0x55f9e1850060, img: 200x70
    0.118691 (+00000.000048) pixbuf renderer updated - started drawing 0x55f9e1850060, img: 200x70
    0.118716 (+00000.000025) pixbuf renderer updated - started drawing 0x55f9e1850060, img: 200x70
Using X11 screen profile, length: 1572
update size: 0x55f9e17e2bd0  0 0   412 858
    0.141875 (+00000.023159) pixbuf renderer updated - started drawing 0x55f9e1850060, img: 200x70
    0.148615 (+00000.006740) layout_new: end
Register realtime 0 /home/zyga
    0.152724 (+00000.004109) vflist_refresh: read dir
    0.153138 (+00000.000414) init_exif_time_data: ...
    0.153164 (+00000.000026) vflist_refresh: sort
    0.153184 (+00000.000020) vflist_refresh: populate view
new image loader 0x55f9e1a095a0, bufsize=4096 idle_loop=1
exif read /home/zyga/IMGP0309.DNG, sidecar: -
Usable reduced size (preview) image loaded from file /home/zyga/IMGP0309.DNG
Thread pool num threads: 1
    0.169158 (+00000.015974) vflist_refresh: free filelist
    0.169182 (+00000.000024) vflist_refresh: done
Using custom jpeg loader
    0.169266 (+00000.000084) image reset
    0.169337 (+00000.000071) image begin
new image loader 0x55f9e1a096c0, bufsize=4096 idle_loop=1
Thread pool num threads: 2
Register realtime 0 /home/zyga/IMGP0309.DNG
    0.195389 (+00000.026052) read ahead cancelled for :null
added Xmp.dc.subject /home/zyga/IMGP0309.DNG

Loading options from /home/zyga/.config/geeqie/geeqierc.xml ... done
    0.226107 (+00000.030718) layout_editors_reload_start
    0.226621 (+00000.000514) main: gtk_main
image_load_size_cb: 160x120
    0.235105 (+00000.008484) pixbuf renderer updated - started drawing 0x55f9e1850060, img: 160x120
    0.235135 (+00000.000030) pixbuf renderer updated - started drawing 0x55f9e1850060, img: 160x120
Using X11 screen profile, length: 1572
image activate focus_in 0
update size: 0x55f9e17e2bd0  0 0   1135 1096
    0.265989 (+00000.030854) pixbuf renderer updated - started drawing 0x55f9e1850060, img: 160x120
    0.355162 (+00000.089173) layout_editors_reload_idle_cb: get_desktop_files
    0.355613 (+00000.000451) image done
Notify pane_histogram: /home/zyga/IMGP0309.DNG 0004
freeing image loader 0x55f9e1a096c0 bytes_read=53959132
Notify pane_histogram: /home/zyga/IMGP0309.DNG 0008
Notify osd: /home/zyga/IMGP0309.DNG 0008
Couldn't load icon ufraw: Icon 'ufraw' not present in theme
Couldn't load icon ufraw: Icon 'ufraw' not present in theme
Couldn't load icon ufraw: Icon 'ufraw' not present in theme
    0.404275 (+00000.048662) layout_editors_reload_idle_cb: setup_editors
    0.404737 (+00000.000462) layout_editors_reload_idle_cb: setup_editors done
    0.455261 (+00000.050524) image load completed "/home/zyga/IMGP0309.DNG" (current)
    0.455336 (+00000.000075) pixbuf renderer done 0x55f9e1850060
thumb image done: /home/zyga/IMGP0309.DNG
            from: /home/zyga/IMGP0309.DNG
thumb saving: /home/zyga/IMGP0309.DNG
       saved: /home/zyga/.thumbnails/normal/9c1e8ec4257a10dc2e3d261b0d0d29fb.png
thumb progress: 1 of 1
freeing image loader 0x55f9e1a095a0 bytes_read=52057
monitor /home/zyga/IMGP0309.DNG
monitor /home/zyga



Fedora 23 seems to be buggy!
I had a problem with the installation on the SSD.
https://bugzilla.redhat.com/show_bug.cgi?id=1309119
Comment 10 Pontus Enhager 2016-02-27 00:58:09 EST
The patch in Comment #9 seems to do the trick
Comment 11 Zbigniew Jędrzejewski-Szmek 2016-02-27 16:43:50 EST
Thanks for the notice, and thanks for testing. Rebuilt with the patch in rawhide.

Note You need to log in before you can comment on or make changes to this bug.