Bug 1292275 - /api/v2/locations does not return parameters
Summary: /api/v2/locations does not return parameters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Organizations and Locations
Version: 6.1.5
Hardware: All
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-16 21:31 UTC by Andrew Schofield
Modified: 2019-09-26 14:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:00:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 13386 None None None 2016-04-22 16:51:46 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Andrew Schofield 2015-12-16 21:31:51 UTC
Description of problem:

GET /api/v2/locations/<location> does not return the parameters

Version-Release number of selected component (if applicable):
Satellite 6.1.5

How reproducible:
Repeatable.

Steps to Reproduce:
1. Create a location and in this location assign a parameter.
2. GET /api/v2/locations/<location>
3. Note the output does not contain the parameter:


Actual results:
"parameters": [
    {

    }
  ],


Expected results:
parameters to be populated with the parameters from step 1 above.

Additional info:

This is also the same issue for hammer:

# hammer location info --name <location>

Parameters:
     =>
Organizations:

Comment 2 Brad Buckingham 2016-01-26 17:43:39 UTC
Created redmine issue http://projects.theforeman.org/issues/13386 from this bug

Comment 3 Bryan Kearney 2016-01-26 19:12:42 UTC
Upstream bug component is Provisioning

Comment 4 Bryan Kearney 2016-01-27 09:13:30 UTC
Upstream bug component is Multi Org

Comment 5 Bryan Kearney 2016-02-03 15:12:30 UTC
Upstream bug assigned to szadok@redhat.com

Comment 6 Bryan Kearney 2016-02-09 11:12:21 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13386 has been closed
-------------
Shlomi Zadok
Applied in changeset commit:019a239c93421bb94b57e5683e304a61b35117d7.

Comment 8 jcallaha 2016-03-24 20:44:03 UTC
Verified in Satellite 6.2 beta Snap 5.1.

{
  "total": 1,
  "subtotal": 1,
  "page": 1,
  "per_page": 20,
  "search": null,
  "sort": {
    "by": null,
    "order": null
  },
  "results": [
    {
      "ancestry": null,
      "parent_id": null,
      "parent_name": null,
      "created_at": "2016-03-11 16:29:11 UTC",
      "updated_at": "2016-03-11 16:29:11 UTC",
      "id": 2,
      "name": "Default Location",
      "title": "Default Location",
      "description": null
    }
  ]
}

Comment 11 errata-xmlrpc 2016-07-27 09:00:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.