Bug 1292275 - /api/v2/locations does not return parameters
/api/v2/locations does not return parameters
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Organizations and Locations (Show other bugs)
6.1.5
All Linux
high Severity high (vote)
: Beta
: --
Assigned To: Shlomi Zadok
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 16:31 EST by Andrew Schofield
Modified: 2016-07-27 05:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:00:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13386 None None None 2016-04-22 12:51 EDT

  None (edit)
Description Andrew Schofield 2015-12-16 16:31:51 EST
Description of problem:

GET /api/v2/locations/<location> does not return the parameters

Version-Release number of selected component (if applicable):
Satellite 6.1.5

How reproducible:
Repeatable.

Steps to Reproduce:
1. Create a location and in this location assign a parameter.
2. GET /api/v2/locations/<location>
3. Note the output does not contain the parameter:


Actual results:
"parameters": [
    {

    }
  ],


Expected results:
parameters to be populated with the parameters from step 1 above.

Additional info:

This is also the same issue for hammer:

# hammer location info --name <location>

Parameters:
     =>
Organizations:
Comment 2 Brad Buckingham 2016-01-26 12:43:39 EST
Created redmine issue http://projects.theforeman.org/issues/13386 from this bug
Comment 3 Bryan Kearney 2016-01-26 14:12:42 EST
Upstream bug component is Provisioning
Comment 4 Bryan Kearney 2016-01-27 04:13:30 EST
Upstream bug component is Multi Org
Comment 5 Bryan Kearney 2016-02-03 10:12:30 EST
Upstream bug assigned to szadok@redhat.com
Comment 6 Bryan Kearney 2016-02-09 06:12:21 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13386 has been closed
-------------
Shlomi Zadok
Applied in changeset commit:019a239c93421bb94b57e5683e304a61b35117d7.
Comment 8 jcallaha 2016-03-24 16:44:03 EDT
Verified in Satellite 6.2 beta Snap 5.1.

{
  "total": 1,
  "subtotal": 1,
  "page": 1,
  "per_page": 20,
  "search": null,
  "sort": {
    "by": null,
    "order": null
  },
  "results": [
    {
      "ancestry": null,
      "parent_id": null,
      "parent_name": null,
      "created_at": "2016-03-11 16:29:11 UTC",
      "updated_at": "2016-03-11 16:29:11 UTC",
      "id": 2,
      "name": "Default Location",
      "title": "Default Location",
      "description": null
    }
  ]
}
Comment 11 errata-xmlrpc 2016-07-27 05:00:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.