Bug 1292303 - libscrypt: epel compat, modernize and bump version
libscrypt: epel compat, modernize and bump version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libscrypt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Denis Fateyev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 18:51 EST by Denis Fateyev
Modified: 2016-02-01 18:24 EST (History)
1 user (show)

See Also:
Fixed In Version: libscrypt-1.21-1.fc22 libscrypt-1.21-1.fc23 libscrypt-1.21-1.el7 libscrypt-1.21-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 22:18:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Specfile improvements (1.82 KB, text/plain)
2015-12-16 18:51 EST, Denis Fateyev
no flags Details

  None (edit)
Description Denis Fateyev 2015-12-16 18:51:38 EST
Created attachment 1106558 [details]
Specfile improvements

Please consider applying the patch attached.

* Explicitly adding "-fPIC" for el6 branch since '_hardened_build' doesn't work as expected there (all other kept untouched).

* Explicit trivial BRs as requested by new policy. Now we don't always rely on pre-installed build env.

* Make install cosmetic changes, to be more clear ("%make_install" is a bit mess, imho).

* License tag introduction, with a workaround for el6.

* Bump version to 1.21.
Comment 1 Denis Fateyev 2015-12-23 06:57:15 EST
Appeal to the maintainer: please improve the spec and update package version. We can discuss details here, or you just can write me by e-mail.
Otherwise, I'll run nonresponsive maintainer procedure since there is no contact, package was outdated in Fedora branches, no any co-maintainers, and there is no way to provide EPEL branches.
Comment 2 Fedora Admin XMLRPC Client 2016-01-16 03:19:40 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Update System 2016-01-17 02:32:45 EST
libscrypt-1.21-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e1c4663bf6
Comment 4 Fedora Update System 2016-01-17 02:32:50 EST
libscrypt-1.21-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-95f6d959c2
Comment 5 Fedora Update System 2016-01-17 02:32:50 EST
libscrypt-1.21-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fe130f41a1
Comment 6 Fedora Update System 2016-01-17 14:18:20 EST
libscrypt-1.21-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e1c4663bf6
Comment 7 Fedora Update System 2016-01-17 14:22:37 EST
libscrypt-1.21-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-54a5e7e12f
Comment 8 Fedora Update System 2016-01-17 14:53:36 EST
libscrypt-1.21-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fe130f41a1
Comment 9 Fedora Update System 2016-01-17 14:54:03 EST
libscrypt-1.21-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-95f6d959c2
Comment 10 Fedora Update System 2016-01-25 22:18:45 EST
libscrypt-1.21-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2016-01-26 13:26:02 EST
libscrypt-1.21-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2016-02-01 17:54:23 EST
libscrypt-1.21-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2016-02-01 18:24:30 EST
libscrypt-1.21-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.