Bug 1292306 - not seeing parameters in nested locations
Summary: not seeing parameters in nested locations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.1.5
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: orabin
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-17 00:12 UTC by Kathryn Dixon
Modified: 2019-08-12 16:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:00:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
parent child location params (62.58 KB, image/png)
2016-04-13 10:22 UTC, Kedar Bidarkar
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Kathryn Dixon 2015-12-17 00:12:02 UTC
Description of problem:

When assigning parameters at the top of the tree (for example, in <region>) we cannot see these in the children. We can add values to the children with the same name and this overwrites as expected. The values parent location are available as parameters in the YAML files. We should be able to view the parents parameters along with options to override these. 

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. manage locations
2. create a new location
3. select a parent for the new location
4. review the location ( you see no parameters)

Actual results:

Child location is separate from the parent.

Expected results:

Child should inherit from the parent including parameters 

Additional info:

Comment 1 Andrew Schofield 2015-12-17 03:40:12 UTC
To give some context, we use nested locations for example:

<region>
|---- <country>
|       |---- <city>

We permission users to have access only to particular parts of this (for various legal and sphere of influence). For example, the region level we will define defaults, some of these may be overwritten at the country / city levels (time zones, root passwords for example) currently these are not visible.

Comment 3 Tomer Brisker 2015-12-23 15:28:48 UTC
Created redmine issue http://projects.theforeman.org/issues/12931 from this bug

Comment 4 Bryan Kearney 2015-12-23 17:02:28 UTC
Upstream bug component is WebUI

Comment 5 Bryan Kearney 2016-01-07 13:02:54 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12931 has been closed
-------------
Ori Rabin
Applied in changeset commit:7422bc43ff93fe4603b6c5a4b71d8dc103e14d67.

Comment 8 Kedar Bidarkar 2016-04-13 10:22:29 UTC
Created attachment 1146782 [details]
parent child location params

VERIFIED With sat62-snap7.1

We can now see parameters in nested locations

Comment 10 errata-xmlrpc 2016-07-27 09:00:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.