Bug 1292308 - amqp-devel Requires: amqp%{?_isa} which is actually noarch
amqp-devel Requires: amqp%{?_isa} which is actually noarch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: amqp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7aarch64
  Show dependency treegraph
 
Reported: 2015-12-16 19:23 EST by Yaakov Selkowitz
Modified: 2015-12-28 18:52 EST (History)
2 users (show)

See Also:
Fixed In Version: amqp-1.0-4.20150701svn1688630.fc23 amqp-1.0-4.20150701svn1688630.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 17:56:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaakov Selkowitz 2015-12-16 19:23:30 EST
amqp.spec contains the following:

BuildArch:      noarch
[snip]
%package devel
Summary: Development files for %{name}
# be careful with epoch!
Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}

As a noarch package, using %{?_isa} doesn't make much sense.  This affects all branches.
Comment 1 Raphael Groner 2015-12-17 13:08:06 EST
Though it works for me in F22, I'll fix that.

[root@poldy ~]# dnf install amqp-devel
Die letzte Prüfung auf abgelaufene Metadaten wurde vor 3:15:41 auf Thu Dec 17 15:50:37 2015 ausgeführt.
Abhängigkeiten sind aufgelöst.
================================================================================
 Package       Arch      Version                               Paketquelle
                                                                          Größe
================================================================================
Installieren:
 amqp          noarch    1:1.0-2.20150624svn1687244.fc22       updates     23 k
 amqp-devel    noarch    1:1.0-2.20150624svn1687244.fc22       updates     40 k

Transaktionsübersicht
================================================================================
Installieren  2 Packages

Gesamte Downloadgröße: 63 k
Installationsgröße: 431 k
Ist dies in Ordnung? [j/N] :j
Pakete werden heruntergeladen:
(1/2): amqp-1.0-2.20150624svn1687244.fc22.noarc 252 kB/s |  23 kB     00:00    
(2/2): amqp-devel-1.0-2.20150624svn1687244.fc22 343 kB/s |  40 kB     00:00    
--------------------------------------------------------------------------------
Gesamt                                           58 kB/s |  63 kB     00:01     
Transaktionsüberprüfung wird ausgeführt
Transaktionsprüfung war erfolgreich.
Transaktion wird getestet
Transaktionstest war erfolgreich.
Transaktion wird ausgeführt
  Installieren     : amqp-1:1.0-2.20150624svn1687244.fc22.noarch            1/2 
  Installieren     : amqp-devel-1:1.0-2.20150624svn1687244.fc22.noarch      2/2 
  Überprüfung läuft: amqp-devel-1:1.0-2.20150624svn1687244.fc22.noarch      1/2 
  Überprüfung läuft: amqp-1:1.0-2.20150624svn1687244.fc22.noarch            2/2 

Installiert:
  amqp.noarch 1:1.0-2.20150624svn1687244.fc22                                   
  amqp-devel.noarch 1:1.0-2.20150624svn1687244.fc22                             

Komplett!
[root@poldy ~]# dnf remove amqp
Abhängigkeiten sind aufgelöst.
================================================================================
 Package       Arch      Version                              Paketquelle Größe
================================================================================
Entfernen:
 amqp          noarch    1:1.0-2.20150624svn1687244.fc22      @updates    105 k
 amqp-devel    noarch    1:1.0-2.20150624svn1687244.fc22      @updates    326 k

Transaktionsübersicht
================================================================================
Entfernen  2 Packages

Installationsgröße: 431 k
Ist dies in Ordnung? [j/N] :j
Transaktionsüberprüfung wird ausgeführt
Transaktionsprüfung war erfolgreich.
Transaktion wird getestet
Transaktionstest war erfolgreich.
Transaktion wird ausgeführt
  Löschen          : amqp-devel-1:1.0-2.20150624svn1687244.fc22.noarch      1/2 
  Löschen          : amqp-1:1.0-2.20150624svn1687244.fc22.noarch            2/2 
  Überprüfung läuft: amqp-devel-1:1.0-2.20150624svn1687244.fc22.noarch      1/2 
  Überprüfung läuft: amqp-1:1.0-2.20150624svn1687244.fc22.noarch            2/2 

Entfernt:
  amqp.noarch 1:1.0-2.20150624svn1687244.fc22                                   
  amqp-devel.noarch 1:1.0-2.20150624svn1687244.fc22                             

Komplett!
Comment 2 Fedora Update System 2015-12-17 13:41:28 EST
amqp-1.0-4.20150701svn1688630.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-505e084a66
Comment 3 Fedora Update System 2015-12-18 06:26:22 EST
amqp-1.0-4.20150701svn1688630.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update amqp'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-505e084a66
Comment 4 Fedora Update System 2015-12-18 06:55:10 EST
amqp-1.0-4.20150701svn1688630.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update amqp'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ca6c9776ae
Comment 5 Fedora Update System 2015-12-28 17:56:39 EST
amqp-1.0-4.20150701svn1688630.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2015-12-28 18:52:00 EST
amqp-1.0-4.20150701svn1688630.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.