This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 129231 - Newest kernel (Aug 3, 2004) missing advansys module
Newest kernel (Aug 3, 2004) missing advansys module
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 09:59 EDT by tjfalcone
Modified: 2015-01-04 17:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 23:10:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tjfalcone 2004-08-05 09:59:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The kernel module "advansys.ko" is no longer found amongst the
prebuilt kernel modules.  (Previously it could be found in
/lib/modules/[kernel-version]/kernel/drivers/scsi/).  Upon
installation of new kernel via "rpm -ivh
kernel-2.6.7-1.494.2.2.i686.rpm", mkinitrd fails since it cannot find
the necessary module.  If I attempt to boot into my new kernel I will
not have access to any of my SCSI devices.

Version-Release number of selected component (if applicable):
kernel-2.6.7-1.494.2.2

How reproducible:
Always

Steps to Reproduce:
1. Install kernel-2.6.7-1.494.2.2.i686.rpm
2. Try to build a new kernel that requires the advansys module 

    

Actual Results:  mkinitrd cannot build initrd for the kernel version.

Expected Results:  New initrd should have been produced.

Additional info:

advansys.c and advansys.h can be found in the kernel source for kernel
2.6.7-1.494.2.2 - I don't understand why the module wasn't built.
Comment 1 Dan Christian 2004-08-05 16:41:40 EDT
FYI, I'm seeing this too (Athlon UP).
Comment 2 Deon George 2004-08-08 02:31:16 EDT
This has got me too... Is there a reason it isnt in the UP & SMP kernels?
Comment 3 Arjan van de Ven 2004-08-08 05:21:06 EDT
The upstream maintainer of the advansys module has marked it BROKEN
(which means you can't select it in the kernel config basically) due
to datacorruption issues he's chasing out.
Comment 4 Jef Spaleta 2004-09-20 14:08:41 EDT
Okay... this brings up a general problem when modules go missing in
update kernels.

What should installation of the kernel rpm do in this situation?
Right now people who were using the advansys module end up installing
the update kernel package and mkinitrd may fail leaving them with no
initrd and no grub entry. Is this the best way to handle this
situation or should the rpm package installation do something more? 
On top of that people using up2date who use this module don't see an
error message at all with regard to mkinitrd failing during the
postinstall of the kernel rpm.  From an average user point of view,
there is precious little information being reported back telling them
a problem occured. Should mkinitrd fail? Should there be more reporint
back to the user?

-jef
Comment 5 Dave Jones 2004-11-18 23:10:22 EST
reenabled in current errata kernels

Note You need to log in before you can comment on or make changes to this bug.