Bug 1292329 - configure mariadb-galera cluster and rabbitmq cluster on separate set of node from the controller via Director
configure mariadb-galera cluster and rabbitmq cluster on separate set of node...
Status: CLOSED DUPLICATE of bug 1292328
Product: Red Hat OpenStack
Classification: Red Hat
Component: RFEs (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: RHOS Maint
: FutureFeature, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 23:42 EST by Pratik Pravin Bandarkar
Modified: 2017-01-13 11:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-13 11:50:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pratik Pravin Bandarkar 2015-12-16 23:42:42 EST
1. Proposed title of this feature request  
       configure mariadb-galera cluster and rabbitmq cluster on separate set of node from the controller via Director
      

    3. What is the nature and description of the request? 
The use case is that in a large scale deployment, running mariadb-galera cluster + rabbitmq-cluster + all API, glance, cinder, other management services etc. on 3 controllers will be causing performance challenges on these controller nodes.
Also, due to large scale - if controller nodes need to be scaled up to handle higher number of API requests + glance and so on, we cannot scale up only controller services without additional database / rabbitmq [as these services are currently tied up with the controller node role / profile]

To avoid such a situation and to be able to scale controller services independently of database / rabbitmq, I want to know the method to do so via director.
Comment 2 Mike Burns 2017-01-13 11:50:45 EST

*** This bug has been marked as a duplicate of bug 1292328 ***

Note You need to log in before you can comment on or make changes to this bug.