This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1292390 - overcloud neutron services are down after deployment
overcloud neutron services are down after deployment
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
x86_64 Linux
urgent Severity urgent
: y3
: 7.0 (Kilo)
Assigned To: Hugh Brock
Amit Ugol
: TestOnly, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 05:01 EST by Amit Ugol
Modified: 2016-03-09 12:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 11:47:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Ugol 2015-12-17 05:01:25 EST
Description of problem:
After deployment, it seems that all neutron services on the overcloud have stopped:
[stack@instack ~]$ . overcloudrc
[stack@instack ~]$ neutron agent-list
+--------------------------------------+--------------------+------------------------------------+-------+----------------+---------------------------+
| id                                   | agent_type         | host                               | alive | admin_state_up | binary                    |
+--------------------------------------+--------------------+------------------------------------+-------+----------------+---------------------------+
| 4d09fcd9-780d-4810-ace4-532303fb2abe | Open vSwitch agent | overcloud-compute-0.localdomain    | :-)   | True           | neutron-openvswitch-agent |
| 7d7e264f-5746-4ced-a0c5-ceacf81b147d | Open vSwitch agent | overcloud-controller-0.localdomain | xxx   | True           | neutron-openvswitch-agent |
| 90937ab5-aba1-4871-b58e-67699f964d04 | DHCP agent         | overcloud-controller-0.localdomain | xxx   | True           | neutron-dhcp-agent        |
| 911d307c-c9c3-444e-b089-03f7304fc3c8 | L3 agent           | overcloud-controller-0.localdomain | xxx   | True           | neutron-l3-agent          |
| fc237f6d-fa49-4b1b-98dd-1aca1bb01679 | Metadata agent     | overcloud-controller-0.localdomain | xxx   | True           | neutron-metadata-agent    |
+--------------------------------------+--------------------+------------------------------------+-------+----------------+---------------------------+

[heat-admin@overcloud-controller-0 ~]$ sudo pcs status --full | grep Stop
     neutron-l3-agent   (systemd:neutron-l3-agent):     Stopped
     Stopped: [ overcloud-controller-0 ]
     neutron-metadata-agent     (systemd:neutron-metadata-agent):       Stopped
     Stopped: [ overcloud-controller-0 ]
     neutron-dhcp-agent (systemd:neutron-dhcp-agent):   Stopped
     Stopped: [ overcloud-controller-0 ]


*** In this case, upgrade should in theory not even start, but not only can I start it, upgrade to 7.1 works.

**** full logs too big to be attached. Please find them in http://ikook.tlv.redhat.com/unrelated/files/logs.tar.xz

Version-Release number of selected component (if applicable):
7.0 GA -
neutron-2015.1.0-12
openstack-puppet-modules-2015.1.8-8
pcs-0.9.137-13

How reproducible:
always on 7.0. 7.1 seems to not be effected.

Steps to Reproduce:
1. Deploy 7.0 GA.

Actual results:
Neutron services on the controller nodes stops after a few minutes.

Expected results:
All services should be up and running.

Additional info:
Comment 1 Amit Ugol 2015-12-17 05:43:46 EST
After restarting the services manually and waiting for some time, they seem to be up and running just fine now with no other change to the system.
Comment 3 Hugh Brock 2016-02-05 09:39:40 EST
We can't test this against 8.0 because there is only 1 8.0 version :). Please retest against 7.3.
Comment 6 errata-xmlrpc 2016-02-18 11:47:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html
Comment 7 Amit Ugol 2016-03-09 12:05:36 EST
since it got closed, I'll just clear that need info state

Note You need to log in before you can comment on or make changes to this bug.