Bug 1292409 - [RFE] Allow root CA configuration for SSL enabled Openstack connectivity
[RFE] Allow root CA configuration for SSL enabled Openstack connectivity
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Ladislav Smola
Ola Pavlenko
openstack:configuration
: FutureFeature, ZStream
Depends On:
Blocks: 1292488
  Show dependency treegraph
 
Reported: 2015-12-17 06:12 EST by Marius Cornea
Modified: 2017-08-29 23:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1292488 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:22:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-12-17 06:12:50 EST
Description of problem:
We need to be able to specify a root CA certificate used for the Openstack SSL connectivity. 

Upstream PR:
https://github.com/ManageIQ/manageiq/pull/5831
Comment 3 Ronnie Rasouli 2016-01-26 04:51:26 EST
tested on 5.5.2.2.20160121120249_395c086
with SSL configured on 7.3 

Copied both CA for undercloud and overcloud to CFME

modified in configure-> configuration-> advanced 
ssl:
ssl_ca_file: "/etc/pki/tls/certs/ca-bundle.crt"
ssl_ca_path

Both undercloud and overcloud with SSL are working
Comment 4 Ronnie Rasouli 2016-01-26 05:00:34 EST
target release 5.6.0
Comment 5 Ronnie Rasouli 2016-06-14 04:39:36 EDT
Copied both CA for undercloud and overcloud to CFME

modified in configure-> configuration-> advanced 
ssl:
ssl_ca_file: "/etc/pki/tls/certs/ca-bundle.crt"
ssl_ca_path

Adding cloud provider works
Comment 7 errata-xmlrpc 2016-06-29 11:22:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.