Bug 1292458 - sssd_be AD segfaults on missing A record
sssd_be AD segfaults on missing A record
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.6
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Pavel Březina
Steeve Goveas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 09:11 EST by Martin Kosek
Modified: 2016-05-10 16:25 EDT (History)
10 users (show)

See Also:
Fixed In Version: sssd-1.13.3-11.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:25:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kosek 2015-12-17 09:11:15 EST
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/2904

When using sssd on CentOS 6.6 with the AD backend against a Samba 4.2 AD domain, sssd does not handle a rare failure condition; when the SRV records point at a DC but the A record for that domain controller is missing. sssd_be periodically crashes, it restarts a couple times but generally does not recover:

Dec 16 09:44:05 host kernel: sssd_be[107682]: segfault at 0 ip 00007fd12c5e018b sp 00007fffba8db420 error 4 in libsss_ad.so[7fd12c5ca000+20000]
Dec 16 09:44:05 host abrtd: Directory 'ccpp-2015-12-16-09:44:05-107682' creation detected
Dec 16 09:44:05 host abrt[107687]: Saved core dump of pid 107682 (/usr/libexec/sssd/sssd_be) to /var/spool/abrt/ccpp-2015-12-16-09:44:05-107682 (1978368 bytes)

The SIGSEGV appears to happen in sss_ldap_init_send(), src/util/sss_ldap.c:331.

Getting into this condition is rare - it's a Samba bug that I'm working on separately. The situation could probably be replicated by poisoning DNS though. My expected behavior would be to give up on this DC, try any other DCs in the Site, then try other DCs in other Sites.

I have ABRT crashes and cores / backtraces from GDB.
Comment 1 Jakub Hrozek 2016-01-19 12:08:49 EST
 * master: 8bd9ec3a8885b01a34863d22aa784e221fc422fb
 * sssd-1-13: b32ea7b1f91b4194e05a1a965310691075ecba23
Comment 4 Dan Lavu 2016-03-21 09:35:34 EDT
Verified sanity only, against sssd-client-1.13.3-19.el6.x86_64, SSSD did not crash.


[root@sssdqe5 ~]# id administrator@domain.com
uid=129100790(administrator@domain.com) gid=1606600583(domain users@domain.com) groups=1606600583(domain users@domain.com),139544400(group policy creator owners@domain.com),1606600582(domain admins@domain.com),1606600588(schema admins@domain.com),1425621082(denied rodc password replication group@domain.com),1606600589(enterprise admins@domain.com)
Comment 6 errata-xmlrpc 2016-05-10 16:25:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0782.html

Note You need to log in before you can comment on or make changes to this bug.