Bug 1292487 - Fix GSS-Proxy to work with krb5-1.14
Summary: Fix GSS-Proxy to work with krb5-1.14
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gssproxy   
(Show other bugs)
Version: 7.3
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Robbie Harwood
QA Contact: Namita Soman
Mirek Jahoda
URL:
Whiteboard:
Keywords:
: 1414302 (view as bug list)
Depends On:
Blocks: 1296125 1313485 1292153
TreeView+ depends on / blocked
 
Reported: 2015-12-17 15:02 UTC by Robbie Harwood
Modified: 2017-01-27 21:13 UTC (History)
5 users (show)

Fixed In Version: gssproxy-0.4.1-8.el7
Doc Type: Enhancement
Doc Text:
_gssproxy_ now supports _krb5_ 1.14 The _gssproxy_ packages, which provide a daemon to manage access to GSSAPI credentials, as well as a GSSAPI interposer plug-in, have been updated to upstream version 0.4.1-10. _gssproxy_ now supports the _krb5_ packages in version 1.14.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 03:04:04 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2304 normal SHIPPED_LIVE gssproxy bug fix update 2016-11-03 13:39:57 UTC

Description Robbie Harwood 2015-12-17 15:02:43 UTC
In fedora, I have just patched gssproxy-0.4.1 and krb5-1.14 to work together: https://bodhi.fedoraproject.org/updates/gssproxy-0.4.1-4.fc23%20krb5-1.14-4.fc23

In order to bring krb5-1.14 into RHEL7, we will need to patch GSS-Proxy as well (and probably apply the krb5 fix too).

Comment 3 Kaleem 2016-07-20 14:42:38 UTC
Please provide steps to verify this.

Comment 4 Robbie Harwood 2016-07-20 20:31:48 UTC
(In reply to Kaleem from comment #3)
> Please provide steps to verify this.

If memory serves - the test suite passing with krb5 1.14 is sufficient.  You can verify that a change has been made by running against the rhel-7.2 krb5.

Comment 5 Kaleem 2016-08-24 15:11:00 UTC
Verified. Executed tests mentioned in #c4 with help from Robbie and it passed.

gssproxy version:
=================
gssproxy-0.4.1-10.el7.src.rpm

Please find the attached file for console output.

Comment 8 errata-xmlrpc 2016-11-04 03:04:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2304.html

Comment 9 Robbie Harwood 2017-01-27 21:13:48 UTC
*** Bug 1414302 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.