Bug 1292500 - 3.1 upgrade playbooks mangle registry and router image names
3.1 upgrade playbooks mangle registry and router image names
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Scott Dodson
Anping Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 10:27 EST by Scott Dodson
Modified: 2016-01-27 14:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:43:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dodson 2015-12-17 10:27:33 EST
Extraneous output from the check that generates the list of available versions was leaking into the version string we were setting on upgrades. See https://github.com/openshift/openshift-ansible/issues/1072

And interim fix https://github.com/openshift/openshift-ansible/pull/1076

This is an issue in all currently shipped versions of the installer.
Comment 1 Anping Li 2015-12-20 20:34:16 EST
The fix works well. it can wipe off those unexpected lines, and the upgrade succeeded, so move status to Verified
Comment 3 errata-xmlrpc 2016-01-27 14:43:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0075

Note You need to log in before you can comment on or make changes to this bug.