This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1292503 - instance stuck at migrating state when some unexpected error happened
instance stuck at migrating state when some unexpected error happened
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
high Severity high
: async
: 6.0 (Juno)
Assigned To: Sahid Ferdjaoui
Prasanth Anbalagan
: Triaged, ZStream
Depends On: 1283318
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 10:44 EST by Sahid Ferdjaoui
Modified: 2016-02-22 07:33 EST (History)
15 users (show)

See Also:
Fixed In Version: openstack-nova-2014.2.3-47.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the code responsible for initializing live migration of instances did not handle some exceptions that could be raised. If an unexpected exception was raised, the code could not handle it, and the instance would enter an unpredictable state. With this update, the code has been improved to handle unexpected exceptions and convert them to a knowing MigrationError's exception, which allows instances that experience unexpected exceptions to enter an error state, which is expected. The code now also rolls back any actions.
Story Points: ---
Clone Of: 1283318
Environment:
Last Closed: 2016-02-22 07:33:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1397153 None None None 2016-01-04 10:19 EST
OpenStack gerrit 133269 None None None 2015-12-17 10:44 EST

  None (edit)
Comment 8 errata-xmlrpc 2016-02-22 07:33:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0283.html

Note You need to log in before you can comment on or make changes to this bug.