Bug 1292504 - Ironic: Allow setting uefi_pxe_bootfile_name configuration option
Ironic: Allow setting uefi_pxe_bootfile_name configuration option
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Emilien Macchi
Raviv Bar-Tal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 10:50 EST by Lucas Alvares Gomes
Modified: 2016-04-07 17:19 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.4-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:19:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1525989 None None None 2015-12-17 10:50 EST
OpenStack gerrit 259080 None None None 2015-12-17 10:52 EST
OpenStack gerrit 259940 None None None 2015-12-22 06:24 EST

  None (edit)
Description Lucas Alvares Gomes 2015-12-17 10:50:10 EST
Description of problem:

We need to extend the ironic puppet module to allow setting the [pxe] uefi_pxe_bootfile_name configuration option to enable UEFI booting.

Version-Release number of selected component (if applicable):
8.0
Comment 2 Gaël Chamoulaud 2015-12-22 06:24:52 EST
backport into stable/liberty proposed https://review.openstack.org/#/c/259940/
Comment 5 Raviv Bar-Tal 2016-03-30 09:28:44 EDT
Default value is set to: $uefi_pxe_bootfile_name = 'elilo.efi'
In the file:  /etc/puppet/modules/ironic/manifests/drivers/pxe.pp
Comment 6 errata-xmlrpc 2016-04-07 17:19:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.