Bug 1292513 - Missing dependency on GUI
Missing dependency on GUI
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tor-arm (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Juan Orti
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 11:11 EST by Peter Ludikovsky
Modified: 2015-12-28 17:56 EST (History)
1 user (show)

See Also:
Fixed In Version: tor-arm-1.4.5.0-11.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 17:56:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ludikovsky 2015-12-17 11:11:36 EST
Description of problem:
tor-arm-gui is missing an dependency for Glade

Version-Release number of selected component (if applicable):
tor-arm-gui 1.4.5.0-10.fc23

How reproducible:
Always

Steps to Reproduce:
1. Uninstall pygtk2-libglade
2. Fresh install tor-arm-gui
3. Attempt to start arm -g

Actual results:
Missing dependency error

$ arm -g
Controller password: 
Traceback (most recent call last):
  File "/usr/share/arm/starter.py", line 573, in <module>
    import gui.controller
  File "/usr/share/arm/gui/controller.py", line 8, in <module>
    from gui.graphing import bandwidthStats
  File "/usr/share/arm/gui/graphing/bandwidthStats.py", line 10, in <module>
    from gui.graphing import graphPanel
  File "/usr/share/arm/gui/graphing/graphPanel.py", line 18, in <module>
    from cagraph.ca_graph_grid import CaGraphGrid
  File "/usr/lib/python2.7/site-packages/cagraph/ca_graph_grid.py", line 23, in <module>
    import gtk, gtk.glade
ImportError: No module named glade

Expected results:
arm GUI starting

Additional info:
can be triaged by manually installing pygtk2-libglade
Comment 1 Fedora Update System 2015-12-17 12:47:48 EST
tor-arm-1.4.5.0-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-9176198eeb
Comment 2 Fedora Update System 2015-12-18 06:55:19 EST
tor-arm-1.4.5.0-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update tor-arm'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-9176198eeb
Comment 3 Peter Ludikovsky 2015-12-18 12:02:47 EST
Update works for me.
Comment 4 Fedora Update System 2015-12-28 17:56:48 EST
tor-arm-1.4.5.0-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.