Bug 1292543 - [BUG] accounts-daemon process memory grows until all memory is gone
[BUG] accounts-daemon process memory grows until all memory is gone
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: accountsservice (Show other bugs)
7.1
Unspecified Linux
unspecified Severity high
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 12:51 EST by Sam Roza
Modified: 2017-01-27 22:14 EST (History)
3 users (show)

See Also:
Fixed In Version: accountsservice-0.6.35-11.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 03:51:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2522 normal SHIPPED_LIVE accountsservice bug fix update 2016-11-03 10:15:43 EDT

  None (edit)
Description Sam Roza 2015-12-17 12:51:54 EST
Description of problem: Over time, on servers with frequent SSH connections, the accounts-daemon grows very large until the server is out of memory and causes OOMs.


Version-Release number of selected component (if applicable):
 Accountsservice-0.6.35-7

How reproducible:
 Always.

Steps to Reproduce:
1. Install RHEL 7.1
2. Enable graphical target
3. Log into server frequently using SSH
4. Monitor size of accounts-daemon process

Actual results:
 accounts-daemon process continues to grow until all memory is gone

Expected results:
 accounts-daemon should not consume as much memory as possible

Additional info:
 Workaround exists: https://bugs.launchpad.net/ubuntu/+source/accountsservice/+bug/1316830

sudo mv /usr/share/dbus-1/system-services/org.freedesktop.Accounts.service /usr/share/dbus-1/system-services/org.freedesktop.Accounts.service.disabled
Comment 7 errata-xmlrpc 2016-11-04 03:51:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2522.html

Note You need to log in before you can comment on or make changes to this bug.