This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1292548 - python-Levenshtein: please provide a Python 3 package
python-Levenshtein: please provide a Python 3 package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-Levenshtein (Show other bugs)
24
All All
unspecified Severity low
: ---
: ---
Assigned To: Dwayne Bailey
Fedora Extras Quality Assurance
:
Depends On: 1036607
Blocks: PYTHON3 PY3PATCH-PUSH
  Show dependency treegraph
 
Reported: 2015-12-17 13:15 EST by David H. Gutteridge
Modified: 2016-11-16 10:57 EST (History)
6 users (show)

See Also:
Fixed In Version: python-Levenshtein-0.12.0-1.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-16 10:51:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add Python 3 & version update (4.78 KB, patch)
2016-08-29 08:45 EDT, Dominika Krejčí
no flags Details | Diff
add Python 3 & update version (4.61 KB, patch)
2016-09-20 04:50 EDT, Dominika Krejčí
no flags Details | Diff

  None (edit)
Description David H. Gutteridge 2015-12-17 13:15:01 EST
Upstream, this software supports Python 3. Please provide a Python 3
package for Fedora.

According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
Comment 1 Petr Viktorin 2016-02-15 09:03:11 EST
If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!
Comment 2 Jan Kurik 2016-02-24 10:43:47 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Dominika Krejčí 2016-04-20 09:32:34 EDT
Hello Dwayne,

Do you need any help adding Python 3 support to the RPM?

If you need more instructions, a [guide] for porting Python-based RPMs is available.

[guide] http://python-rpm-porting.readthedocs.org/en/latest/index.html
Comment 4 Dominika Krejčí 2016-08-29 08:45 EDT
Created attachment 1195375 [details]
add Python 3 & version update

Hi Dwayne,
here is the change needed to add Python 3 support and update the version. Could you please review it and do the update?

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=15427465

Also tested in Mock (fedora-23-x86_64, fedora-24-x86_64, fedora-25-x86_64, fedora-rawhide-x86_64, fedora-rawhide-i386).
Comment 5 Lumír Balhar 2016-09-12 06:01:41 EDT
Hello, Dominiko.

Your patch looks good to me but it needs to be modified because it contains changelog entry from Fedora Release Engineering.
Comment 6 Dominika Krejčí 2016-09-20 04:50 EDT
Created attachment 1202777 [details]
add Python 3 & update version

Hi Lumír, thanks for the review. There is a fixed patch. :)
Comment 7 Lumír Balhar 2016-09-21 05:53:48 EDT
Now the patch looks good to me, thanks. If maintainer has nothing against, we can push this change after a week.
Comment 8 Dennis Chen 2016-11-02 21:37:12 EDT
Any progress on this?
Comment 9 Charalampos Stratakis 2016-11-16 10:52:01 EST
Fixed for rawhide, please reopen the bug if you require it for F25.

Note You need to log in before you can comment on or make changes to this bug.