Bug 1292566 - Rebase request for crash utility RHEL7.3 errata
Rebase request for crash utility RHEL7.3 errata
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: crash (Show other bugs)
7.3
All Linux
high Severity high
: rc
: ---
Assigned To: Dave Anderson
Emma Wu
Marie Dolezelova
: Rebase
Depends On:
Blocks: 1295826 1296180 1313485
  Show dependency treegraph
 
Reported: 2015-12-17 14:56 EST by Dave Anderson
Modified: 2017-06-27 01:32 EDT (History)
4 users (show)

See Also:
Fixed In Version: crash-7.1.5-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_crash_ rebased to version 7.1.5 The _crash_ packages have been upgraded to upstream version 7.1.5, which provides several bug fixes and a number of enhancements over the previous version. Notably, this rebase adds new options such as `dis -s`, `dis -f`, `sys -i`, `list -l`, new support for Quick Emulator (QEMU) generated Executable and Linkable Format (ELF) vmcores on the 64-bit ARM architectures, and several updates required for support of recent upstream kernels. It is safer and more efficient to rebase the *crash* packages than to backport selectively the individual patches.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 23:45:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2325 normal SHIPPED_LIVE crash bug fix and enhancement update 2016-11-03 09:43:41 EDT

  None (edit)
Description Dave Anderson 2015-12-17 14:56:26 EST
Description of problem:

The RHEL7.3 errata version of the crash utility should be
rebased to the current upstream version, currently at version
crash-7.1.4.  There are over 50 new features and other fixes 
that have been applied to the upstream version make the tool 
significantly more useful than the current RHEL7.2 version, 
which is based upon crash-7.1.2.  This includes new options such
as "dis -s", "dis -f", "sys -i", "list -l", new support for QEMU
generated ARM64 ELF vmcores, and several updates required for 
support of recent upstream kernels, which is now relevant given
that the RHEL7 ARM64 kernel has been rebased to upstream Linux 
version 4.4.  

It is far more efficient, and far safer, to rebase the crash 
package than to attempt to selectively backport individual patches.
As the owner and upstream maintainer, one of my primary goals is,
and always has been, to maintain backwards-compatibility whenever 
new fixes or features are applied.  The risk of regression is 
less with a rebase than it would be with selective backports.

It should be noted that nothing goes into the upstream version 
without my approval.  I perform all my testing on Fedora and RHEL
kernel versions, where each individual change is meticulously 
tested against a sample set of RHEL3, RHEL4, RHEL5, RHEL6, RHEL7,
and Fedora crash dumps.

Details regarding recent fixes, features and enhancements can be found in:

  http://people.redhat.com/anderson/crash.changelog.html


Version-Release number of selected component (if applicable):

crash-7.1.2-3.el7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 5 errata-xmlrpc 2016-11-03 23:45:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2325.html

Note You need to log in before you can comment on or make changes to this bug.