This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1292580 - WebUI: Host: Services: Error "undefined method `id' for nil:NilClass [host/host_services]" found while accessing Services
WebUI: Host: Services: Error "undefined method `id' for nil:NilClass [host/ho...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity medium
: GA
: 5.5.2
Assigned To: Harpreet Kataria
Nandini Chandra
: ZStream
Depends On: 1290403 1292581
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 15:20 EST by John Prause
Modified: 2016-02-10 10:29 EST (History)
7 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290403
Environment:
Last Closed: 2016-02-10 10:29:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Harpreet Kataria 2015-12-18 12:00:40 EST
upstream: https://github.com/ManageIQ/manageiq/pull/5908
Comment 3 CFME Bot 2015-12-18 13:06:55 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/9ce78c7ce1415b191172eb77dccc8fab5c89870f

commit 9ce78c7ce1415b191172eb77dccc8fab5c89870f
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 18 11:58:06 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Dec 18 11:58:06 2015 -0500

    Reset @display to 'main' when viewing list of associations.
    
    Fixed show details method to set @display to 'main' to fix links to associations from Host summary screen
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290403
    https://bugzilla.redhat.com/show_bug.cgi?id=1292581
    https://bugzilla.redhat.com/show_bug.cgi?id=1292580

 .../application_controller/ci_processing.rb        |  1 +
 spec/views/host/_show.html.haml_spec.rb            | 54 ++++++++++++++++++++++
 2 files changed, 55 insertions(+)
 create mode 100644 spec/views/host/_show.html.haml_spec.rb
Comment 5 CFME Bot 2015-12-18 16:12:27 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=e96d9518dd369df1ee7bab1baddf92ec220a76b3

commit e96d9518dd369df1ee7bab1baddf92ec220a76b3
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 18 11:58:06 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Dec 18 13:58:58 2015 -0500

    Reset @display to 'main' when viewing list of associations.
    
    Fixed show details method to set @display to 'main' to fix links to associations from Host summary screen
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290403
    https://bugzilla.redhat.com/show_bug.cgi?id=1292581
    https://bugzilla.redhat.com/show_bug.cgi?id=1292580
    (cherry picked from commit 9ce78c7)

 .../application_controller/ci_processing.rb        |  1 +
 spec/views/host/_show.html.haml_spec.rb            | 54 ++++++++++++++++++++++
 2 files changed, 55 insertions(+)
 create mode 100644 spec/views/host/_show.html.haml_spec.rb
Comment 6 CFME Bot 2015-12-18 16:12:40 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=1b7b4df9a7c3723ccf1500e3fddb90d3e2db1939

commit 1b7b4df9a7c3723ccf1500e3fddb90d3e2db1939
Merge: c77451d e96d951
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Dec 18 16:04:25 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Dec 18 16:04:25 2015 -0500

    Merge branch '55z_pr_5908' into '5.5.z'
    
    Reset @display to 'main' when viewing list of associations.
    
    Fixed show details method to set @display to 'main' to fix links to associations from Host summary screen
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290403
    https://bugzilla.redhat.com/show_bug.cgi?id=1292581
    https://bugzilla.redhat.com/show_bug.cgi?id=1292580
    (cherry picked from commit 9ce78c7)
    
    @dclarizi this is clean cherry-pick to 5.5.z for https://github.com/ManageIQ/manageiq/pull/5908
    
    See merge request !644

 .../application_controller/ci_processing.rb        |  1 +
 spec/views/host/_show.html.haml_spec.rb            | 54 ++++++++++++++++++++++
 2 files changed, 55 insertions(+)
Comment 7 CFME Bot 2015-12-18 17:49:01 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=38b6b6f72e46e6c1fc7d03c6cf223f11002f2ecd

commit 38b6b6f72e46e6c1fc7d03c6cf223f11002f2ecd
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 18 14:02:31 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Dec 18 16:17:14 2015 -0500

    Reset @display to 'main' when viewing list of associations.
    
    Fixed show details method to set @display to 'main' to fix links to associations from Host summary screen
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290403
    https://bugzilla.redhat.com/show_bug.cgi?id=1292581
    https://bugzilla.redhat.com/show_bug.cgi?id=1292580
    (cherry picked from commit 9ce78c7)

 .../application_controller/ci_processing.rb        |  1 +
 vmdb/spec/views/host/_show.html.haml_spec.rb       | 55 ++++++++++++++++++++++
 2 files changed, 56 insertions(+)
 create mode 100644 vmdb/spec/views/host/_show.html.haml_spec.rb
Comment 8 CFME Bot 2015-12-18 17:49:22 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=f1901eb16a1774ee37a9217ab29a457e7fdd75cc

commit f1901eb16a1774ee37a9217ab29a457e7fdd75cc
Merge: 0eed03b 38b6b6f
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Dec 18 17:46:12 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Dec 18 17:46:12 2015 -0500

    Merge branch '54z_pr_5908' into '5.4.z'
    
    Reset @display to 'main' when viewing list of associations.
    
    Fixed show details method to set @display to 'main' to fix links to associations from Host summary screen
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290403
    https://bugzilla.redhat.com/show_bug.cgi?id=1292581
    https://bugzilla.redhat.com/show_bug.cgi?id=1292580
    (cherry picked from commit 9ce78c7)
    
    See merge request !645

 .../application_controller/ci_processing.rb        |  1 +
 vmdb/spec/views/host/_show.html.haml_spec.rb       | 55 ++++++++++++++++++++++
 2 files changed, 56 insertions(+)
Comment 10 Nandini Chandra 2016-01-18 12:57:18 EST
Verified in 5.5.2.1
Comment 11 errata-xmlrpc 2016-02-10 10:29:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.