Bug 1292649 - DSUtil.pm - allow users to specify to relax the FQDN constraint
DSUtil.pm - allow users to specify to relax the FQDN constraint
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
Petr Bokoc
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 19:36 EST by Noriko Hosoi
Modified: 2016-05-10 15:22 EDT (History)
5 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-72.el6
Doc Type: Bug Fix
Doc Text:
When creating a server instance, the setup script checks that the FQDN can be strictly resolved. But there is a requirent the constraint is not necessary. To solve the problem, an option to relax the constraint is added. If "General.StrictHostCheck=false", setup script accepts the host name specified by General.FullMachineName without checking the name against the DNS server.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 15:22:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Hosoi 2015-12-17 19:36:04 EST
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/48332

When creating a server instance, DSUtil::checkHostname checks that the FQDN can be strictly resolved.

It is necessary for the Admin Server installation via setup-ds-admin.pl, but there could be a case the constraint is not necessary.  That said, it should be useful to add an option to relax the constraint.
Comment 1 Viktor Ashirov 2016-01-03 16:08:38 EST
New option should be documented. Doc bug added: bz1295235
Comment 6 errata-xmlrpc 2016-05-10 15:22:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0737.html

Note You need to log in before you can comment on or make changes to this bug.