Bug 1292671 - [tiering]: cluster.tier-max-files option in tiering is not honored
[tiering]: cluster.tier-max-files option in tiering is not honored
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
: ZStream
Depends On: 1291152
Blocks: 1292945
  Show dependency treegraph
 
Reported: 2015-12-17 21:01 EST by Dan Lambright
Modified: 2016-06-16 09:51 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1291152
: 1292945 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:51:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-17 21:03:36 EST
REVIEW: http://review.gluster.org/12984 (cluster/tier: fix tier-max-files bookeeping and help) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 2 Vijay Bellur 2015-12-18 11:28:04 EST
COMMIT: http://review.gluster.org/12984 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 9644769ea174646eaf18b8a41873f67928be9c8d
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Tue Dec 15 19:30:45 2015 -0500

    cluster/tier: fix tier-max-files bookeeping and help
    
    The option tier-max-files represents the maximum number
    of files trasferred by a node in a gives cycle. Fix help message
    to reflect the "per node" aspect. The code transferred one
    more file per cycle than the given value.
    
    Also change the default values of max file and max bytes to
    very large values, effectively we will not throttle migration
    unless the administrator requests it via CLI.
    
    Change-Id: Ic2949ed3d8c35afe7c9ae4db72195603cfb2e28f
    BUG: 1292671
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/12984
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Mike McCune 2016-03-28 18:28:36 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Niels de Vos 2016-06-16 09:51:17 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.