Bug 1292692 - "Download CSV" when searching for systems with given installed package gives me less rows than whats displayed on webUI
"Download CSV" when searching for systems with given installed package gives ...
Status: CLOSED DUPLICATE of bug 1098141
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
570
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Grant Gainey
Red Hat Satellite QA List
: Triaged
Depends On:
Blocks: sat580-low
  Show dependency treegraph
 
Reported: 2015-12-18 00:30 EST by Jan Hutař
Modified: 2017-01-18 15:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-18 15:26:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2015-12-18 00:30:51 EST
Description of problem:
"Download CSV" link when searching for systems with given installed package gives me less rows than what is displayed on webUI


Version-Release number of selected component (if applicable):
spacewalk-java-2.3.8-120.el6sat.noarch


How reproducible:
always


Steps to Reproduce:
1. Log into Sat5
2. Systems
3. Advanced Search
   1. Search for: curl
   2. Field to search: Installed Packages
   3. Where to Search: Search all systems
4. After some time I get a paginated result that lists "1 - 25 of 2,637"
5. At the bottom of the page there is a "Download CSV" button, when I
   click that I get a file with 138 lines only (header + 137 systems)


Actual results:
webUI indicates it found 2,637 matching systems, csv file contains only 137 systems. There is no traceback/message in the logs.


Expected results:
All systems visible on webUI are in the csv.


Additional info:
Originally reported by Ian Tewksbury <itewksbu@redhat.com> - thanks!
Comment 1 Bryan Kearney 2016-07-26 15:08:02 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 2 Grant Gainey 2017-01-18 15:26:14 EST

*** This bug has been marked as a duplicate of bug 1098141 ***

Note You need to log in before you can comment on or make changes to this bug.