Bug 1292724 - Enki not usable without plugins
Enki not usable without plugins
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: enki (Show other bugs)
rawhide
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
:
: 1292725 (view as bug list)
Depends On:
Blocks: LXQt
  Show dependency treegraph
 
Reported: 2015-12-18 03:14 EST by Yajo
Modified: 2016-01-30 23:33 EST (History)
2 users (show)

See Also:
Fixed In Version: enki-15.11.0-2.fc22 enki-15.11.1-1.fc23 enki-15.11.0-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 18:55:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yajo 2015-12-18 03:14:58 EST
Description of problem:
Many Enki menus cannot be used.

Version-Release number of selected component (if applicable):
enki-15.11.0-1.fc23.noarch
python2-qutepart-2.2.2-3.fc23.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Open Enki.
2. Some menu items that do not work:
   - File
     - Open Project
     - Open
   - View
     - Opened files
     - Hide all/restore
   - Navigation
     - Search & replace
     - File browser
   - Tools
   - Help

Actual results:
They do nothing.

Expected results:
Do something.

Additional info:
Comment 1 Raphael Groner 2015-12-18 04:05:31 EST
Thanks for your detailed report. Please forward this to upstream.
Comment 2 Raphael Groner 2015-12-18 04:06:35 EST
Save file does not work either. But there's a message box when you try to close Enki while an unsaved modification is in window.
Comment 3 Andrei Kopats 2016-01-04 14:55:58 EST
Hi
I'm the Enki maintainer.

Now there are 2 packages in the repositories - `enki` and `enki-plugins`. And it seems like `enki-plugins` is not installed.

Could you join 2 packages to 1? The division onto core and plugins is a way to build internal architecture. For a user Enki is not usable without plugins.

I encountered one more problem. Menu items are not visible. `>>` is shown instead and menu is opened vertically. Will check this.
Comment 4 Yajo 2016-01-05 03:24:30 EST
Thanks Andrei! I can confirm that installing enki-plugins fixes the bug. Maybe packagers wanted to split it like in gedit, just in case more plugin packages come in the future. In such case, just adding the dependency should do the trick.
Comment 5 Raphael Groner 2016-01-09 11:50:41 EST
I doubt we can expect any package or even an use case that needs enki-plugins without enki itself. I'll merge plugins into enki.
Comment 6 Raphael Groner 2016-01-09 12:18:43 EST
*** Bug 1292725 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2016-01-09 12:42:31 EST
enki-15.11.0-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f154dc4371
Comment 8 Fedora Update System 2016-01-09 12:42:31 EST
enki-15.11.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-35eb73f03b
Comment 9 Fedora Update System 2016-01-09 12:54:35 EST
enki-15.11.0-2.el7 python-qutepart-2.2.2-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-c3e2a2e9f9
Comment 10 Fedora Update System 2016-01-09 12:54:44 EST
enki-15.11.0-2.el7 python-qutepart-2.2.2-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-c3e2a2e9f9
Comment 11 Fedora Update System 2016-01-10 14:50:20 EST
enki-15.11.0-2.el7, python-qutepart-2.2.2-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-c3e2a2e9f9
Comment 12 Fedora Update System 2016-01-10 15:24:23 EST
enki-15.11.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-35eb73f03b
Comment 13 Fedora Update System 2016-01-10 15:54:20 EST
enki-15.11.0-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f154dc4371
Comment 14 Fedora Update System 2016-01-14 06:25:54 EST
enki-15.11.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d93d4bbaaf
Comment 15 Fedora Update System 2016-01-15 13:54:13 EST
enki-15.11.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d93d4bbaaf
Comment 16 Fedora Update System 2016-01-19 18:55:40 EST
enki-15.11.0-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2016-01-23 22:32:55 EST
enki-15.11.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2016-01-30 23:33:22 EST
enki-15.11.0-2.el7, python-qutepart-2.2.2-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.