Bug 1292736 - running virt-who in big vmware environments results in to fast growing logfiles
running virt-who in big vmware environments results in to fast growing logfiles
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who (Show other bugs)
7.3
All All
high Severity medium
: alpha
: 7.3
Assigned To: Radek Novacek
Eko
: ZStream
: 1355624 (view as bug list)
Depends On: 1281715 1355624
Blocks: 1203710 1296845 1298337 1313485 1369473
  Show dependency treegraph
 
Reported: 2015-12-18 03:58 EST by Christian Horn
Modified: 2016-11-30 19:36 EST (History)
17 users (show)

See Also:
Fixed In Version: virt-who-0.17-1.el7
Doc Type: Bug Fix
Doc Text:
Previously, virt-who was very verbose when writing to its log file. As a result, the log file grew very quickly, especially in large environments. Now, virt-who logs significantly less information in non-debug mode, and the log file thus grows slower.
Story Points: ---
Clone Of: 1281715
: 1369473 (view as bug list)
Environment:
Last Closed: 2016-11-04 01:07:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2049753 None None None 2015-12-18 03:58 EST

  None (edit)
Comment 2 Christian Horn 2015-12-18 04:03:53 EST
We need this fix also in rhel7.
Comment 4 Radek Novacek 2016-03-08 01:48:15 EST
This is already fixed upstream and will be resolved by rebase.
Comment 6 Radek Novacek 2016-05-17 08:59:53 EDT
Fixed in virt-who-0.17-1.el7.
Comment 8 Radek Novacek 2016-07-12 02:13:43 EDT
*** Bug 1355624 has been marked as a duplicate of this bug. ***
Comment 9 Eko 2016-07-18 01:01:38 EDT
verified with virt-who-0.17-6.el7
disable DEBUG option, there is no host/guests json info in rhsm.log
enable DEBUG option, will print the json info
Comment 13 Radek Novacek 2016-07-26 08:59:33 EDT
Deepannagaraj, it is possible to do a hotfix for this bug. Please follow official hotfix process and propose this bug for z-stream.

https://mojo.redhat.com/docs/DOC-80399
Comment 18 Radek Novacek 2016-09-29 01:43:00 EDT
Mithun,

virt-who logs to the /var/log/rhsm/rhsm.log file. If something in /var/log/foreman/ is growing too fast, I would guess it is a different issue. But it would be best if someone can analyze the big file for log entries that are filling it. Only that way we can be sure what is the problem there.
Comment 19 Evgeni Golov 2016-09-29 03:58:02 EDT
(In reply to Radek Novacek from comment #18)
> Mithun,
> 
> virt-who logs to the /var/log/rhsm/rhsm.log file. If something in
> /var/log/foreman/ is growing too fast, I would guess it is a different
> issue. But it would be best if someone can analyze the big file for log
> entries that are filling it. Only that way we can be sure what is the
> problem there.

Radek,

virt-who submits data to Candlepin via Foreman/Katello.
Sadly Foreman will log the whole request (incl the full JSON) to production log. So thats the reason for foreman/production.log to grow.
Same happens in Candlepin, see c11 for a workaround.
Comment 21 Radek Novacek 2016-10-06 02:10:01 EDT
Mithun,

does the customer use filter_hosts/exclude_hosts options to run virt-who only against systems that do run Red Hat servers? If not, you might suggest it to them, I think it would both reduce the load and generate less logs.
Comment 23 errata-xmlrpc 2016-11-04 01:07:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2387.html

Note You need to log in before you can comment on or make changes to this bug.