Bug 1292749 - Friend update floods can render the cluster incapable of handling other commands
Friend update floods can render the cluster incapable of handling other commands
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks: 1291386 1294410
  Show dependency treegraph
 
Reported: 2015-12-18 04:36 EST by Kaushal
Modified: 2016-06-16 09:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1294410 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:51:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaushal 2015-12-18 04:36:58 EST
A flood of glusterd friend updates happen whenever a glusterd restarts and re-establishes all it's connections.

In a large cluster (100s) nodes, this would go on for several minutes. During this period the cluster isn't able to respond to commands. Simple local commands, like `gluster volume list` will take relatively very long time to complete.

When a large number of nodes come back up simultaneously, say due to a network problem, this flood can last for a long time, longer than expected.
Comment 1 Vijay Bellur 2015-12-18 04:44:02 EST
REVIEW: http://review.gluster.org/12999 (glusterd: reduce friend update flood) posted (#1) for review on master by Kaushal M (kaushal@redhat.com)
Comment 2 Vijay Bellur 2015-12-22 00:09:18 EST
REVIEW: http://review.gluster.org/12999 (glusterd: reduce friend update flood) posted (#2) for review on master by Kaushal M (kaushal@redhat.com)
Comment 3 Vijay Bellur 2015-12-22 22:52:32 EST
COMMIT: http://review.gluster.org/12999 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit f624abd6885752eeaa8d07101ff00f52af48de26
Author: Kaushal M <kaushal@redhat.com>
Date:   Thu Dec 17 11:13:36 2015 +0530

    glusterd: reduce friend update flood
    
    When in a befriended state, glusterd would broadcast friend updates to
    all other peers whenver a ACC or LOCAL_ACC event occurred.
    
    When a downed glusterd came back up and established connections again,
    this lead to a flood of friend updates to happen on the order of N^2 (N
    is the number of peers in the cluster)
    
    In larger clusters this was problematic, and could lead to very long
    times for the cluster to settle down when a peer came back up. Multiple
    peers coming back up at the same time would compound the problem.
    
    Broadcasting of friend updates doesn't have much use in places other
    that during a peer probe. Instead of broadcasting friend updates on
    connection re-establishment, updates can just be exchanged between the
    peers involved in the connection.
    
    This patch changes the glusterd friend state-machine to send updates
    only to the required peer for ACC or LOCAL_ACC events when in befriended
    state. The number of updates sent now is in the order of N.
    
    For a 10 node cluster, the number of updates reduced by 5 times. When
    creating the 10 node cluster, the updates reduced from ~500 to ~150.
    When a glusterd restarted, the number of exchanges reduced from ~160 to
    ~35.
    
    BUG: 1292749
    Change-Id: Ib6072090c7069b081d018cdaa3dc878819ab1d18
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/12999
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Niels de Vos 2016-06-16 09:51:17 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.