This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1292750 - "Suggest new" link for IP address on interface model window doesn't work
"Suggest new" link for IP address on interface model window doesn't work
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Marek Hulan
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 04:38 EST by Sachin Ghai
Modified: 2016-07-27 05:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:00:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12859 None None None 2016-04-22 12:42 EDT

  None (edit)
Description Sachin Ghai 2015-12-18 04:38:10 EST
I defined two interfaces 1) Primary and 2) Provisioning with different subnets. However, for none of them the "suggest New" IP link works. I didn't get any error in firebug nor in any logs. Nothing happens on clicking the link.

reproducible with version:
foreman-release-1.11.0-0.develop.201512091815git0e9b35e.el7.noarch
Comment 1 Sachin Ghai 2015-12-18 04:38:15 EST
Created from redmine issue http://projects.theforeman.org/issues/12859
Comment 2 Sachin Ghai 2015-12-18 04:38:27 EST
Upstream bug assigned to mhulan@redhat.com
Comment 4 Bryan Kearney 2016-01-12 06:01:08 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/12859 has been closed
-------------
Marek Hulán
Introduced by (accidental) removing of emptying the IP field, for more details see https://github.com/theforeman/foreman/pull/2650/files#diff-63d9ef3bbe6ac020529a197ac7aa171bL523ac020529a197ac7aa171bL523

Not a blocker but should be fixed in 1.10.1 I think
-------------
Marek Hulán
Applied in changeset commit:d03db507341885416e99f518c66f8931e5d42dab.
Comment 7 Sachin Ghai 2016-04-11 08:00:35 EDT
Verified with sat6beta snap6.2


The reported issue has been fixed. I can see newly generated IP on clicking 'suggest new' link from webUI:


here are the production.log:
===========================
2016-04-09 07:08:13 [app] [I] Started POST "/subnets/freeip" for 10.67.7.83 at 2016-04-09 07:08:13 -0400
2016-04-09 07:08:13 [app] [I] Processing by SubnetsController#freeip as JSON
2016-04-09 07:08:13 [app] [I]   Parameters: {"subnet_id"=>"1", "host_mac"=>"", "organization_id"=>"1", "location_id"=>"2", "taken_ips"=>["192.168.100.32", ""]}
2016-04-09 07:08:15 [app] [I] Completed 200 OK in 2085ms (Views: 0.2ms | ActiveRecord: 4.9ms)

And If I associate a static subnet where dhcp proxy is not set, webUI stick with old ip.
Comment 9 errata-xmlrpc 2016-07-27 05:00:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.