Bug 1292764 - max() arg is an empty sequence
max() arg is an empty sequence
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atomic (Show other bugs)
7.4
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 05:00 EST by Alex Jia
Modified: 2016-03-31 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 19:25:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0527 normal SHIPPED_LIVE atomic bug fix and enhancement update 2016-03-31 23:20:15 EDT

  None (edit)
Description Alex Jia 2015-12-18 05:00:17 EST
Description of problem:
When list of images are empty, atomic images will hit a python error 'max() arg is an empty sequence', which is not friendly for users.

Version-Release number of selected component (if applicable):
# rpm -q atomic docker
atomic-1.7-3.git95b28a9.el7.x86_64
docker-1.9.1-9.el7.x86_64

How reproducible:
always.

Steps to Reproduce:
1. make sure no avaiable images in docker
2. atomic images

Actual results:
# docker images
REPOSITORY          TAG                 IMAGE ID            CREATED             VIRTUAL SIZE

# atomic images
max() arg is an empty sequence

Expected results:
# atomic images
There are no images available.

Additional info:

https://github.com/projectatomic/atomic/pull/260
Comment 2 Daniel Walsh 2016-01-31 23:40:32 EST
Fixed in atomic-1.8
Comment 4 Alex Jia 2016-03-10 05:08:35 EST
This issue has been fixed by the atomic-1.8-3.git958d939.el7 and works well on latest atomic-1.9-4.gitff44c6a.el7.x86_64, so moving the bug to VERIFIED status.

# rpm -q atomic docker python-docker-py
atomic-1.8-3.git958d939.el7.x86_64
docker-1.9.0-9.el7.x86_64
python-docker-py-1.6.0-1.el7.x86_64

[root@hp-dl360g9-03 ~]# atomic images
[root@hp-dl360g9-03 ~]# echo $?
0


[root@hp-dl360g9-03 ~]# rpm -q atomic docker python-docker-py
atomic-1.9-4.gitff44c6a.el7.x86_64
docker-1.9.1-19.el7.x86_64
python-docker-py-1.7.2-1.el7.noarch


[root@hp-dl360g9-03 ~]# atomic images
[root@hp-dl360g9-03 ~]# echo $?
0
Comment 6 errata-xmlrpc 2016-03-31 19:25:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0527.html

Note You need to log in before you can comment on or make changes to this bug.