Bug 1292777 - Stylesheet.css not found for javadoc generation
Stylesheet.css not found for javadoc generation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
22
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michael Simacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1208281
  Show dependency treegraph
 
Reported: 2015-12-18 05:22 EST by Raphael Groner
Modified: 2016-01-07 22:22 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-05 16:56:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (16.75 KB, text/plain)
2015-12-18 05:23 EST, Raphael Groner
no flags Details
root.log (80.90 KB, text/plain)
2015-12-18 05:23 EST, Raphael Groner
no flags Details

  None (edit)
Description Raphael Groner 2015-12-18 05:22:19 EST
Description of problem:
  [javadoc] Constructing Javadoc information...
  [javadoc] Creating destination directory: "/builddir/build/BUILD/mockito-1.10.19/target/javadoc/"
  [javadoc] Standard Doclet version 1.8.0_65
  [javadoc] Building tree for all the packages and classes...
  [javadoc] javadoc: error - java.io.FileNotFoundException: /builddir/build/BUILD/mockito-1.10.19/javadoc/stylesheet.css (No such file or directory) encountered while 
  [javadoc] performing copy.
  [javadoc] javadoc: error - /builddir/build/BUILD/mockito-1.10.19/javadoc/stylesheet.css (No such file or directory)
  [javadoc] Generating /builddir/build/BUILD/mockito-1.10.19/target/javadoc/serialized-form.html...
  [javadoc] Copying file StandardDocFile[file:/builddir/build/BUILD/mockito-1.10.19/javadoc/stylesheet.css] to file stylesheet.css...
  [javadoc] 2 errors

Version-Release number of selected component (if applicable):
ant-1.9.4-7.fc22.noarch

How reproducible:
yes

Steps to Reproduce:
1. fedpkg clone mockito ; cd mockito && fedpkg switch-branch f22
2. fedpkg scratch-build
3.

Actual results:
see error above

Expected results:
build package mockito works

Additional info:
Not sure if ant is the right component to blame.
Comment 2 Raphael Groner 2015-12-18 05:23 EST
Created attachment 1107072 [details]
root.log
Comment 3 Raphael Groner 2015-12-18 09:56:03 EST
This bug is reproducible in F22 only, but build works without this error in F23 and rawhide.
Comment 4 gil cattaneo 2015-12-22 10:59:30 EST
for me it's not a problem
at least should be changed "stylesheetfile="javadoc/stylesheet.css"" with 
"additionalparam="-Xdoclint:none""
cause of many errors during javadoc task @ https://kojipkgs.fedoraproject.org//work/tasks/8578/12238578/build.log
Comment 5 Raphael Groner 2015-12-25 10:19:17 EST
Gil, can you explain with more details what you write in comment #4, please?
Comment 6 Fedora Update System 2015-12-25 10:22:38 EST
mockito-1.10.19-7.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-9e9b03cde3
Comment 7 gil cattaneo 2015-12-25 16:56:53 EST
(In reply to Raphael Groner from comment #5)
> Gil, can you explain with more details what you write in comment #4, please?

javadoc/stylesheet.css should be considered as "optional" resources
and for remove some javadoc warning you can use additionalparam="-Xdoclint:none"
in place of of the stylesheetfile instruction

the build fails because of unavailable aqute-bnd executable (/usr/bin/bnd) not for the missing css file

  [javadoc] 2 errors
     [copy] Copying 1 file to /builddir/build/BUILD/mockito-1.10.19/target/javadoc/org/mockito
BUILD SUCCESSFUL
Total time: 6 seconds
+ pushd target
~/build/BUILD/mockito-1.10.19/target ~/build/BUILD/mockito-1.10.19
+ bnd wrap --output mockito-core-1.10.19.bar --properties ../conf/mockito-core.bnd --version 1.10.19 mockito-core-1.10.19.jar
/var/tmp/rpm-tmp.mirBfs: line 35: bnd: command not found

other issues with the latest changes in the spec file:
the NOTICE file should be considered as part of the package license
so it should be used for this the %license macro
e.g. %license LICENSE NOTICE
Comment 8 Fedora Update System 2015-12-28 19:56:22 EST
mockito-1.10.19-7.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-9e9b03cde3
Comment 9 Fedora Update System 2015-12-30 15:55:17 EST
mockito-1.10.19-7.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b87e13ba8a
Comment 10 Fedora Update System 2016-01-05 16:56:21 EST
mockito-1.10.19-7.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2016-01-07 22:22:55 EST
mockito-1.10.19-7.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.