Bug 1292815 - usermod -p allowing colon (ie. ':' ) in encrypted password which then breaks /etc/shadow
usermod -p allowing colon (ie. ':' ) in encrypted password which then breaks ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: shadow-utils (Show other bugs)
7.2
All Linux
high Severity medium
: rc
: ---
Assigned To: Tomas Mraz
Stefan Kremen
:
Depends On:
Blocks: 1203710 1296594 1313485
  Show dependency treegraph
 
Reported: 2015-12-18 07:24 EST by Tomas Mraz
Modified: 2016-11-03 23:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: shadow-utils-4.1.5.1-19.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1220504
Environment:
Last Closed: 2016-11-03 23:41:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1444893 None None None 2015-12-18 07:24 EST

  None (edit)
Description Tomas Mraz 2015-12-18 07:24:59 EST
Description of problem:
usermod -p allowing colon (ie. ':' ) in encrypted password which then breaks /etc/shadow


Version-Release number of selected component (if applicable):
shadow-utils-4.1.4.2-19.el6_6.1.x86_64

How reproducible:
VERY

Steps to Reproduce:
1. Create test user
# useradd test
# passwd test
# grep ^test: /etc/shadow
test:$6$ziMs4I5K$yh6QO6q4siNK8j.CMxCBO.hjF75XlQZzl7I2dXIJqnANNvhMwFtdDY2obXOjGnniPcVTpSazk5REcTKGHVEUb1:16566:0:99999:7:::

2. Modify user password with usermod and include colon
# usermod -p 'sstest:123' test

3. Now see that the ':' was accepted even though it is really a delimiter for the file
# grep ^test: /etc/shadow
test:sstest:123:16566:0:99999:7:::


Actual results:
# grep ^test: /etc/shadow
test:sstest:123:16566:0:99999:7:::


Expected results:
A failure like you get on RHEL 7
# usermod -p 'sstest:123' test
usermod: failure while writing changes to /etc/shadow


Additional info:
If you run the usermod again you start adding duplicate lines:

# usermod -p 'sstest:123' test
# grep ^test: /etc/shadow
test:sstest:123:16566:0:99999:7:::
test:sstest:123:16566:0:99999:7:::
Comment 2 James Hartsock 2015-12-18 10:25:41 EST
I opened the RHEL 6 verstion of the BZ, and included in the Expected results above is that RHEL 7 already warns of this issue.  So not sure this BZ is needed for RHEL 7...


# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.2 (Maipo)
# grep ^test: /etc/shadow
test:$6$iimWa/Hp$h2Vx0aM1WD/Z.khihwBnpRocSLTc8PgVNIwFjRejYpp74JxToLo6IrgaT.1CZDrbw9cYXfLt494aDQsweU6/60:16787:0:99999:7:::
# usermod -p 'sstest:123' test
usermod: failure while writing changes to /etc/shadow
# grep ^test: /etc/shadow
test:$6$iimWa/Hp$h2Vx0aM1WD/Z.khihwBnpRocSLTc8PgVNIwFjRejYpp74JxToLo6IrgaT.1CZDrbw9cYXfLt494aDQsweU6/60:16787:0:99999:7:::



Now with colon removed on RHEL 7 (so seems the colon is cause of failure):
# usermod -p 'sstest123' test
# grep ^test: /etc/shadow
test:sstest123:16787:0:99999:7:::
Comment 3 Tomas Mraz 2015-12-21 04:56:13 EST
Hmm, you're right that there is additional check when writing the shadow entry. However the error message is not completely clear so it is better to include the explicit check for ':' which will be in RHEL-6.8.
Comment 8 errata-xmlrpc 2016-11-03 23:41:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2322.html

Note You need to log in before you can comment on or make changes to this bug.