Bug 1292819 - sort sorts different
sort sorts different
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 07:32 EST by Marcus Moeller
Modified: 2015-12-18 08:54 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-18 08:40:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sorted list created on 8.22 (5.22 KB, text/plain)
2015-12-18 07:32 EST, Marcus Moeller
no flags Details
sorted list created on 8.23 (5.22 KB, text/plain)
2015-12-18 07:33 EST, Marcus Moeller
no flags Details

  None (edit)
Description Marcus Moeller 2015-12-18 07:32:09 EST
Description of problem:
On one machine we have got coreutils 8.22-15 and on another machine we have got 8.23-10.

We are executing a sort on a list of checksums on both machines. The input data is the same, but the result is different when it contains two or more files with the same checksum.

I have attached two files for both versions. The output has been created with the following command:

find . -type f -exec md5sum {} \; | sort
Comment 1 Marcus Moeller 2015-12-18 07:32 EST
Created attachment 1107117 [details]
sorted list created on 8.22
Comment 2 Marcus Moeller 2015-12-18 07:33 EST
Created attachment 1107118 [details]
sorted list created on 8.23
Comment 3 PƔdraig Brady 2015-12-18 08:40:04 EST
The two attachments are different due to different inputs,
rather than different sorting order:

--- 8.22.txt
+++ 8.23.txt
+be61b01fd8631d488c5a17d8c4b00146  ./.metadata/.plugins/org.eclipse.e4.workbench/workbench.xmi
-c6ede12325019d608f28dee4165fa814  ./.metadata/.plugins/org.eclipse.e4.workbench/workbench.xmi


BTW your checksum will proceed faster by minimizing the number of md5sum processes by using '+' in your command rather than '\;'
Comment 4 Marcus Moeller 2015-12-18 08:54:57 EST
Thanks for taking care and sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.