Bug 1292829 - virt-install: support disk blockio
virt-install: support disk blockio
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 07:58 EST by Yuri Arabadji
Modified: 2017-06-16 13:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-16 13:29:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager-blksize.patch (1.08 KB, patch)
2017-06-16 11:30 EDT, Yuri Arabadji
no flags Details | Diff

  None (edit)
Description Yuri Arabadji 2015-12-18 07:58:05 EST
Please add blockio config support. Also, it would be totally great if you could add support for specifying custom qemu parameters, for ex., currently that's possible only via domain xml:

 <qemu:commandline>
   <qemu:arg value='--blah'/>
 </qemu:commandline>


Or maybe there's already a way to adjust virt-install' generated template before it's fed to domain launch utility? If so, what are the steps?

Thanks.
Comment 1 Cole Robinson 2015-12-23 15:12:58 EST
virt-install doesn't use a template, it builds the XML from scratch. There isn't any general purpose way to insert bits into the XML, but you could do virt-install --print-xml, edit it, then define and run it manually.

FWIW the libvirt XML for blockio bits is:

<disk>
  <blockio logical_block_size='512' physical_block_size='512'/>
</disk>

Supported since libvirt 0.10.2
Comment 2 Yuri Arabadji 2017-06-16 11:30 EDT
Created attachment 1288392 [details]
virt-manager-blksize.patch

"Thanks" for taking care of this so promptly.

I've created a tiny patch that adds logical_block_size and physical_block_size to --disk option. It's working perfectly so far.
Comment 3 Cole Robinson 2017-06-16 13:29:28 EDT
Thanks for the patch, pushed now with some test suite additions:

commit 4be3d030b5425fee5108675ba5a744223842c11c (HEAD -> master, origin/master, origin/HEAD)
Author: Yuri Arabadji <yuri@deepunix.net>
Date:   Fri Jun 16 13:27:38 2017 -0400

    cli: Add --disk logical/physical_block_size


Also virt-install does have command line passthrough support now, with the --qemu-commandline option

Note You need to log in before you can comment on or make changes to this bug.