Bug 1292860 - Custom Attributes do not display correctly in reports
Custom Attributes do not display correctly in reports
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
5.5.0
x86_64 Linux
high Severity high
: GA
: 5.7.0
Assigned To: Libor Pichler
Jiri Stefanisin
report
:
: 1292859 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 09:55 EST by Jesse P. Johnson
Modified: 2017-01-04 07:54 EST (History)
8 users (show)

See Also:
Fixed In Version: 5.7.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-04 07:54:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example poorly formated spreadsheet (47.62 KB, image/png)
2015-12-18 09:55 EST, Jesse P. Johnson
no flags Details

  None (edit)
Description Jesse P. Johnson 2015-12-18 09:55:07 EST
Created attachment 1107188 [details]
Example poorly formated spreadsheet

Description of problem:
Custom attributes are used to store data that is not normally provided by Cloudforms. These key/value pairs do not display correctly when used in reports. All custom attributes are displayed in the same columns and requires multiple rows. A report for 500 machines with 5 custom attributes will consume 2500 lines.

Version-Release number of selected component (if applicable):
5.4.0
5.5.0
5.6.0?

How reproducible:
Always

Steps to Reproduce:
1. Create custom attribute for VM in CFME
2. Populate custom attribute with data
3. Create report that displays "EVM Custom Attributes : {Name,Value}"
4. Generate report

Actual results:
Denormalized spreadsheet

Expected results:
Normalized spreadsheet with custom headers and other available formatting

Additional info:
Comment 2 Tim Wade 2016-01-08 18:33:43 EST
*** Bug 1292859 has been marked as a duplicate of this bug. ***
Comment 3 Dustin Boyd 2016-02-23 12:30:31 EST
Workaround - Spreadsheet filters on the CSV export to get useful data with the current formatting of the report.
Comment 8 errata-xmlrpc 2017-01-04 07:54:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0012.html

Note You need to log in before you can comment on or make changes to this bug.