Bug 1292865 - [RFE] Allow 'foreman' user to read logs under '/var/log/foreman-proxy'
[RFE] Allow 'foreman' user to read logs under '/var/log/foreman-proxy'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Uncategorized (Show other bugs)
6.1.5
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks: rhci-common-installer
  Show dependency treegraph
 
Reported: 2015-12-18 10:05 EST by John Matthews
Modified: 2016-12-18 04:20 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-18 04:20:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2015-12-18 10:05:24 EST
Description of problem:

In RHCI we require the ability of the 'foreman' user to be able to read the logs generated by 'foreman-proxy'.

Currently the logs for /var/log/foreman-proxy are owned by:  foreman-proxy:foreman-proxy and they are 750.

We need 'foreman' to be able to read these logs.

In general, RHCI requests that the 'foreman' user has access to read all logs generated by Satellite-6.
Comment 1 Ohad Levy 2015-12-20 04:13:07 EST
Dmitri - does your work on exposing proxy status via the API can be an alternative to parsing log files?
Comment 2 Dmitri Dolguikh 2016-05-31 05:39:00 EDT
Smart-proxy's log module provides access to smart-proxy logs. Those can be accessed via /log api end point.
Comment 3 Bryan Kearney 2016-07-26 15:07:51 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 4 Ohad Levy 2016-12-18 04:20:57 EST
Since satellite 6.2 the smart proxy component has an API to return its logs, it can be visible under the infra -> capsules -> select the one you wish, assuming it has the proxy log feature enabled.

You may also parse this information via a plugin, or a rest api call to the proxy if you are developing a plugin on top of satellite.

I'm closing this due to the above, please re-open if you disagree. thanks!

Note You need to log in before you can comment on or make changes to this bug.