Bug 1292881 - BR thinkpad keyboard layout not listed
BR thinkpad keyboard layout not listed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xkeyboard-config (Show other bugs)
23
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 11:02 EST by Max de Bayser
Modified: 2015-12-24 19:24 EST (History)
3 users (show)

See Also:
Fixed In Version: xkeyboard-config-2.16-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-24 19:24:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max de Bayser 2015-12-18 11:02:02 EST
In file /usr/share/X11/xkb/symbols/br of package xkeyboard-config-2.16-1.fc23.noarch there is a keymap called thinkpad that correct the problem of the slash/question key being interpreted as Right Control instead on some Thinkpad models. However, this layout is not available to the user because it is not included in the index files: /usr/share/X11/xkb/rules/{evdev.lst, evdev.xml, base.lst, base,xml}. When the layout is added to these files, it automatically becomes available in KDE/Gnome/Xfce keyboard settings.
Comment 1 Fedora Update System 2015-12-21 22:11:16 EST
xkeyboard-config-2.16-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-934f79dc89
Comment 2 Fedora Update System 2015-12-22 19:10:19 EST
xkeyboard-config-2.16-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-934f79dc89
Comment 3 Fedora Update System 2015-12-24 19:24:29 EST
xkeyboard-config-2.16-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.