Bug 1292883 - nouveau custom edid
nouveau custom edid
Status: CLOSED DUPLICATE of bug 1314923
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 11:05 EST by rikm.net@gmail.com
Modified: 2017-01-03 11:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 15:23:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mostly just the above report in a more readable format (5.01 KB, text/plain)
2015-12-18 11:05 EST, rikm.net@gmail.com
no flags Details

  None (edit)
Description rikm.net@gmail.com 2015-12-18 11:05:04 EST
Created attachment 1107216 [details]
mostly just the above report in a more readable format

Description of problem:

-kernel 4.2.x nouveau driver with Nvidia GF660 and widescreen flat panel LG 34UM67 will only display 1920x1080

-the native rez for the panel is 2560x1080 but xrandr doesn't show it as available

-the monitor-get-edid utility produces an edid bin that has the correct modeline:

---

Name: LG ULTRAWIDE
EISA ID: GSM59f1
EDID version: 1.3
EDID extension blocks: 1
Screen size: 80.0 cm x 34.0 cm (34.22 inches, aspect ratio 2.39)
Gamma: 2.2
Digital signal
Max video bandwidth: 240 MHz

        HorizSync 30-90
        VertRefresh 56-75

        # Monitor preferred modeline (60.0 Hz vsync, 66.7 kHz hsync, ratio 2.37, 81 dpi)
        ModeLine "2560x1080" 185.58 2560 2624 2688 2784 1080 1083 1093 1111 -hsync -vsync

---

but that edid bin will not load with the KMS kernel parameter and the make process to create a custom edid for the native rez fails with:

---

hobbes:~/video/Documentation-433/EDID$ make
edid.S: Assembler messages:
edid.S:171: Warning: value 0x121 truncated to 0x21
edid.S:175: Error: invalid operands (*UND* and *ABS* sections) for `<<'
Makefile:16: recipe for target '2560x1080.o' failed
make: *** [2560x1080.o] Error 1
rm 1600x1200.o
Press any key to continue...

---


Line 175 in the edid.S file seems to indicate that it is failing on the XY ratio line of 21:9

the homemade 2560x1080.S src is below:


/* EDID */
#define VERSION 1
#define REVISION 3

/* Display */
#define CLOCK 185580 /* kHz */
#define XPIX 2560
#define YPIX 1080
#define XY_RATIO XY_RATIO_21_9
#define XBLANK 224
#define YBLANK 31
#define XOFFSET 64
#define XPULSE 128
#define YOFFSET (63+3)
#define YPULSE (63+13)
#define DPI 81
#define VFREQ 60 /* Hz */
#define TIMING_NAME "Linux LG"
/*#define ESTABLISHED_TIMING2_BITS 0x08 /* Bit 3 -> 1024x768 @60 Hz */
#define HSYNC_POL 0
#define VSYNC_POL 1
#define CRC 0x55

#include "edid.S"

---

also tried the nvidia driver with the 'CustomEDID' parameter without success

the nvidia-settings utility shows the preferred monitor rez but ignores the edid.bin it generates and still only works at 1920x1080




Version-Release number of selected component (if applicable):

-tried the make from the 4.2x and the 4.3x kernel src 
-with the edid binary from both the get-edid utility and the nvidia utility
-the kernel src is unchanged
-there was no diff in the parse of the edid bin files


How reproducible:


Steps to Reproduce:
1. run make on the included src
2.
3.

Actual results:

same fail

Expected results:
...was kind of hoping that a custom edid would make the nouveau driver yield the proper rez

Additional info:

thanks and any help appreciated

rikm
Comment 1 Fedora End Of Life 2016-07-19 15:23:39 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 2 Gonéri Le Bouder 2017-01-03 11:40:39 EST

*** This bug has been marked as a duplicate of bug 1314923 ***

Note You need to log in before you can comment on or make changes to this bug.