Bug 1292884 - Cinder create volume from image: AttributeError: 'Schema' object has no attribute 'is_base_property'
Cinder create volume from image: AttributeError: 'Schema' object has no attri...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
high Severity high
: ---
: 6.0 (Juno)
Assigned To: Eric Harney
lkuchlan
: Automation, Regression, ZStream
Depends On: 1290548
Blocks: 1291385
  Show dependency treegraph
 
Reported: 2015-12-18 11:06 EST by Eric Harney
Modified: 2016-04-26 20:44 EDT (History)
12 users (show)

See Also:
Fixed In Version: openstack-cinder-2014.2.4-3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290548
Environment:
Last Closed: 2016-03-10 12:06:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Harney 2015-12-18 11:06:12 EST
+++ This bug was initially created as a clone of Bug #1290548 +++

Cinder create volume from image fails on

openstack-cinder-2015.1.2-3.el7ost and openstack-cinder-2015.1.2-4.el7ost with this error.

This seems to be related to the patch introduced in bug 1280362. "Fix properties extracting from image with glance api".

> Traceback (most recent call last): 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api File "/usr/lib/python2.7/site-packages/taskflow/engines/action_engine/executor.py", line 67, in _execute_task 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api result = task.execute(**arguments) 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api File "/usr/lib/python2.7/site-packages/cinder/volume/flows/api/create_volume.py", line 417, in execute 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api self._check_image_metadata(context, image_id, size) 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api File "/usr/lib/python2.7/site-packages/cinder/volume/flows/api/create_volume.py", line 251, in _check_image_metadata 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api image_meta = self.image_service.show(context, image_id) 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api File "/usr/lib/python2.7/site-packages/cinder/image/glance.py", line 243, in show 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api base_image_meta = self._translate_from_glance(context, image) 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api File "/usr/lib/python2.7/site-packages/cinder/image/glance.py", line 366, in _translate_from_glance 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api for key in image.keys() 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api File "/usr/lib/python2.7/site-packages/cinder/image/glance.py", line 367, in <dictcomp> 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api if self._image_schema.is_base_property(key) is True 
> 2015-12-10 10:52:31.774 325 TRACE cinder.volume.api AttributeError: 'Schema' object has no attribute 'is_base_property' 
>
Comment 1 Sergey Gotliv 2015-12-20 07:48:32 EST
Remove unrelated customer case from that BZ.
Comment 2 Sergey Gotliv 2016-01-03 10:29:16 EST
openstack-cinder-2014.2.3-11.el7ost requires python-glanceclient version equal or greater than 0.14.2-3. We have to fix a sepc file.
Comment 5 lkuchlan 2016-03-06 05:44:13 EST
Tested using:
openstack-cinder-2014.2.4-6.el7ost.noarch
python-cinder-2014.2.4-6.el7ost.noarch
python-cinderclient-1.1.1-1.el7ost.noarch

Verification flow:

[root@cougar14 ~(keystone_admin)]# cinder create 1 --image-id ea360782-4c21-406f-bee8-e1f6566d4f78
+---------------------+--------------------------------------+
|       Property      |                Value                 |
+---------------------+--------------------------------------+
|     attachments     |                  []                  |
|  availability_zone  |                 nova                 |
|       bootable      |                false                 |
|      created_at     |      2016-03-06T10:41:29.924808      |
| display_description |                 None                 |
|     display_name    |                 None                 |
|      encrypted      |                False                 |
|          id         | c053fe8d-15d9-47a4-ac41-04adbbcfa94a |
|       image_id      | ea360782-4c21-406f-bee8-e1f6566d4f78 |
|       metadata      |                  {}                  |
|         size        |                  1                   |
|     snapshot_id     |                 None                 |
|     source_volid    |                 None                 |
|        status       |               creating               |
|     volume_type     |                 None                 |
+---------------------+--------------------------------------+

[root@cougar14 ~(keystone_admin)]# cinder list
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
|                  ID                  |   Status  | Display Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
| c053fe8d-15d9-47a4-ac41-04adbbcfa94a | available |     None     |  1   |     None    |   true   |             |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
Comment 7 errata-xmlrpc 2016-03-10 12:06:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0436.html

Note You need to log in before you can comment on or make changes to this bug.