Bug 1292909 - abrt crashes with "ImportError: No module named argparse"
abrt crashes with "ImportError: No module named argparse"
Status: CLOSED DUPLICATE of bug 1246539
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
i686 Linux
unspecified Severity high
: rc
: ---
Assigned To: abrt
BaseOS QE - Apps
Depends On:
  Show dependency treegraph
Reported: 2015-12-18 12:16 EST by Mikuláš Patočka
Modified: 2015-12-21 03:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-12-21 03:20:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mikuláš Patočka 2015-12-18 12:16:48 EST
Description of problem:
I am frequently getting emails that abrt can't find module argparse. It seems that the abrt package lacks some required dependencies.

Version-Release number of selected component (if applicable):
abrt 2.6.8 34.el6

How reproducible:

Steps to Reproduce:
On each boot it sends email with "ImportError: No module named argparse"

Actual results:
From DoNotReply@rhel-6-i386.localdomain  Fri Dec 18 18:09:54 2015
Return-Path: <DoNotReply@rhel-6-i386.localdomain>
X-Original-To: root@localhost
Delivered-To: root@localhost.localdomain
Received: by rhel-6-i386.localdomain (Postfix, from userid 0)
	id 6BF1D401B9; Fri, 18 Dec 2015 18:09:54 +0100 (CET)
Date: Fri, 18 Dec 2015 18:09:54 +0100
From: ABRT Daemon <DoNotReply@rhel-6-i386.localdomain>
To: root@localhost.localdomain
Subject: [abrt] a crash has been detected again
User-Agent: Heirloom mailx 12.4 7/29/08
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit
Message-Id: <20151218170954.6BF1D401B9@rhel-6-i386.localdomain>

abrt_version:   2.0.8
cmdline:        /usr/bin/python /usr/libexec/abrt-action-generate-machine-id -o /var/spool/abrt/pyhook-2015-12-18-18:09:36-31719/machineid
executable:     /usr/libexec/abrt-action-generate-machine-id
hostname:       rhel-6-i386
kernel:         2.6.32-573.12.1.el6.i686
last_occurrence: 1450458576
time:           Pá 18. prosinec 2015, 18:09:54 CET
uid:            0

:abrt-action-generate-machine-id:24:<module>:ImportError: No module named argparse
:Traceback (most recent call last):
:  File "/usr/libexec/abrt-action-generate-machine-id", line 24, in <module>
:    from argparse import ArgumentParser
:ImportError: No module named argparse
:Local variables in innermost frame:
:__builtins__: <module '__builtin__' (built-in)>
:__file__: '/usr/libexec/abrt-action-generate-machine-id'
:__package__: None
:sys: <module 'sys' (built-in)>
:__name__: '__main__'
:__doc__: 'This module provides algorithms for generating Machine IDs.\n'

Expected results:
abrt should have proper dependencies specified in the rpm file, so that all modules it depends on are automatically installed.

Additional info:
Comment 2 Jakub Filak 2015-12-21 03:20:51 EST
Thank you for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

*** This bug has been marked as a duplicate of bug 1246539 ***

Note You need to log in before you can comment on or make changes to this bug.