Bug 129293 - kerberos ticket forwarding support on openssh
kerberos ticket forwarding support on openssh
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openssh (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 18:30 EDT by Franco M. Bladilo
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-09 08:51:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Franco M. Bladilo 2004-08-05 18:30:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
We need kerberos ticket forwarding support on openssh, our
infrastructure is being
kerberized and many users have already complained about this feature
missing on RHEL3.



Version-Release number of selected component (if applicable):
openssh-3.6.1p2-33.30.1

How reproducible:
Always

Steps to Reproduce:
1.Use the RHEL WS U2 provided openssh (openssh-3.6.1p2-33.30.1)
2.
3.
    

Actual Results:  No kerberos ticket forwarding support.


Additional info:
Comment 1 Jonathan Reed 2004-08-11 15:19:45 EDT
Personally, I think this bug is more than just an "enhancement"

Here at MIT we're running into this issue.  The SPEC file for the SRPM has this neat little 
line in it:

# Apply gss-specific patches only if the release tag includes "gss".  (Not
# to be used for actual releases until it's in the mainline.)
if echo "%{release}" | grep -q gss; then
%patch11 -p1 -b .gssapi
autoreconf
fi

If you add 'gss' to the release tag, or simply comment out the "if" clause, and rebuild the 
RPM, the patch gets applied, and ssh behaves as expected.  

It's most unfortunate that the GSSAPI patch has been left out of the mainline release.  It's 
been around for quite some time, and is in widespread use in other distributions.  Without 
this patch, OpenSSH is mostly useless in any Kerberized infrastructure.  Is there any 
chance that this patch can make into mainline releases before RHEL 4.0?  Alternatively, can 
you provide two packages, one with GSSAPI, and one without, until such time?  Having an 
OpenSSH client with Kerberos support in this half-broken state is alienating a number of 
large educational institutions.
Comment 2 seph 2004-09-15 16:14:01 EDT
particularly as authconfig supports kerberos. Are there any plans to
fix this, or has it fallen through the cracks since it's flagged as an
enhancement?
Comment 3 Tomas Mraz 2005-02-09 08:51:01 EST
No, there are currently no such plans and note that the patch in the
SRPM is incompatible with the gssapi implementation in the current
openssh-3.9p1.

Note You need to log in before you can comment on or make changes to this bug.