Bug 1292962 - [RFE] oc new-app doesn't support authenticated registries
[RFE] oc new-app doesn't support authenticated registries
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Ben Parees
weiwei jiang
:
Depends On: 1292963
Blocks: 1267746 1278974
  Show dependency treegraph
 
Reported: 2015-12-18 16:18 EST by Ryan Howe
Modified: 2016-10-30 18:55 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1278974
Environment:
Last Closed: 2016-07-19 15:05:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1324213 None None None 2016-07-11 13:50 EDT

  None (edit)
Comment 1 Michal Minar 2016-02-04 11:39:50 EST
Fixed by PRs #6288 #6800.
Comment 2 weiwei jiang 2016-02-16 03:18:13 EST
checked with devenv_rhel7_3433 with private dockerhub image, and work well. 
Since can not use insecure https registry due to https://bugzilla.redhat.com/show_bug.cgi?id=1302549#c3 .
Comment 3 weiwei jiang 2016-03-18 02:33:46 EDT
Checked with ose atomic-openshift-3.2.0.4-1.git.0.4717e23.el7.x86_64.rpm 
And still can not work due to this bug https://bugzilla.redhat.com/show_bug.cgi?id=1310052.
Comment 4 Ben Parees 2016-07-19 15:05:48 EDT
We are not considering adding the ability to specify push/pull secrets as part of new-app invocation right now as it is not a common use case.

Note You need to log in before you can comment on or make changes to this bug.