Bug 1292970 - Fritzing segmentation fault when trying to save file
Fritzing segmentation fault when trying to save file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fritzing (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ed Marshall
Fedora Extras Quality Assurance
: Reopened
: 1293013 1293014 1293057 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 16:57 EST by linux4fun
Modified: 2016-01-07 22:21 EST (History)
3 users (show)

See Also:
Fixed In Version: fritzing-0.9.2b-2.fc23 fritzing-0.9.2b-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-05 16:55:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description linux4fun 2015-12-18 16:57:21 EST
Description of problem:
When I want to save my work, Fritzing crashes with the following line in the log file :
Dec 18 22:51:24 FredLaptop gnome-shell.desktop: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x3801170 (Specify a )
Dec 18 22:51:30 FredLaptop audit: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=1 pid=5958 comm="Fritzing" exe="/usr/bin/Fritzing" sig=11
Dec 18 22:51:30 FredLaptop kernel: Fritzing[5958]: segfault at 7f0ba3c28110 ip 00007f0ba626d89a sp 00007ffc83820520 error 7 in libquazip.so.1.0.0[7f0ba624b000+2e000]

Version-Release number of selected component (if applicable):
fritzing-0.9.2b-1.fc23.x86_64

How reproducible:
Always, I have not been able to save any work since I installed the software

Steps to Reproduce:
1.Start using Fritzing
2.Create a sample circuit
3.Save

Actual results:
Segmentation fault

Expected results:
Work saved

Additional info:
Comment 1 Ed Marshall 2015-12-28 00:11:07 EST
This looks like a problem with the version of quazip that was linked against; I'm working on a fix now.
Comment 2 Ed Marshall 2015-12-28 00:11:40 EST
*** Bug 1293057 has been marked as a duplicate of this bug. ***
Comment 3 Ed Marshall 2015-12-28 00:11:50 EST
*** Bug 1293013 has been marked as a duplicate of this bug. ***
Comment 4 Ed Marshall 2015-12-28 00:11:53 EST
*** Bug 1293014 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2015-12-28 01:46:47 EST
fritzing-0.9.2b-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-628d7f6b46
Comment 6 Fedora Update System 2015-12-28 19:54:59 EST
fritzing-0.9.2b-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1e772cfcd6
Comment 7 linux4fun 2015-12-29 05:20:56 EST
This fixed the issue and I can now save my work properly.

Thank you very much for your help.
Comment 8 Fedora Update System 2015-12-30 15:54:20 EST
fritzing-0.9.2b-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-628d7f6b46
Comment 9 Fedora Update System 2016-01-05 16:55:32 EST
fritzing-0.9.2b-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2016-01-07 22:21:39 EST
fritzing-0.9.2b-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.