Bug 129298 - kacpid randomly runs amok chewing up 99% cpu time.
kacpid randomly runs amok chewing up 99% cpu time.
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 19:29 EDT by Thomas J. Clancy
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Clancy 2004-08-05 19:29:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
I am using Fedora Core 2 with 2.6.7 kernel on my Dell 2.2 GHz Pentium
IV  PC with 512megs ram, 120gig hd, flat panel monitor, pretty much
standard fare.  But for some reason there is a kernel process that
always has a pid of 5 called kacpid.  At some point (and it always
happens) during the time while I am messing around with Linux
(compiling my stuff, checking mail, surfing web, or just away from the
machine for a bit) kacpid will, out of the blue, go friggin' nuts and
start chewing up processor time, usually between 95 and 99%, at which
time I have to reboot.  I've seen some code in the kernel (a function
actuall) called kacpid that is supposed to run as a low priority
thread, but for some reason it goes insane.  I also saw this listed as
a bug elsewhere, but only as a bug pertaining to a laptop PC when one
changes the power from AC to battery, back and forth.  I

Version-Release number of selected component (if applicable):
kernel-2.6.7-1.494.2.2

How reproducible:
Always

Steps to Reproduce:
Just running my machine... it happens at a random time, but it
inevitably happens.  There isn't one specific thing I do.  I could be
just downloading something.  Or typing in open office.  Or I just walk
away and the screen saver comes on with no other user processes really
running in the background.    

Actual Results:  machines crawls so very slow that I have to reboot.

Additional info:
Comment 1 Arjan van de Ven 2004-08-06 03:26:58 EDT
are you using the nvidia binary only driver ?
Comment 2 Arjan van de Ven 2004-08-09 07:46:02 EDT
ping?
Comment 3 Thomas J. Clancy 2004-08-09 12:01:34 EDT
What do you mean "binary only?"  I downloaded the NVIDIA driver and 
installed--the installer had to build it into to kernel for me.  It 
warned about conflicts with an installed module called riva (or 
something similar to that) but I ignored it.  Still, I thought it had 
been causing me problems even before I installed the NVIDIA drivers.  
When I did a fresh install with the 2.6.5 kernel, it would randomly 
freeze (I had to do a hard reboot).  After upgrading the kernel was 
when I noticed no more freeze but rather these inevitable slow downs 
with kacpid going nuts. 
Comment 4 Arjan van de Ven 2004-08-09 12:47:02 EDT
yep those are the binary only nvidia drivers.
We've only seen this report with those drivers involved, and well we
can't fix those drivers because they are binary only.
You're better of reporting this bug to nvidia I suspect.

*** This bug has been marked as a duplicate of 73733 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:04:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.