Bug 1293000 - [abrt] hamster-time-tracker: activityentry.py:214:complete_inline:UnicodeDecodeError: 'utf8' codec can't decode byte 0xd1 in position 0: unexpected end of data
[abrt] hamster-time-tracker: activityentry.py:214:complete_inline:UnicodeDeco...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hamster-time-tracker (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6fc0f7a93db546164d3be6f9dd1...
:
Depends On: 1293039
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 20:02 EST by mastaiza
Modified: 2016-02-12 07:22 EST (History)
3 users (show)

See Also:
Fixed In Version: hamster-time-tracker-2.0-0.2.rc1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-12 07:22:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.86 KB, text/plain)
2015-12-18 20:02 EST, mastaiza
no flags Details
File: environ (982 bytes, text/plain)
2015-12-18 20:02 EST, mastaiza
no flags Details

  None (edit)
Description mastaiza 2015-12-18 20:02:41 EST
Version-Release number of selected component:
hamster-time-tracker-1.04-5.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        python /usr/bin/hamster
executable:     /usr/bin/hamster
kernel:         4.2.6-301.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
activityentry.py:214:complete_inline:UnicodeDecodeError: 'utf8' codec can't decode byte 0xd1 in position 0: unexpected end of data

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/hamster/widgets/activityentry.py", line 308, in _on_key_release_event
    self.complete_inline()
  File "/usr/lib/python2.7/site-packages/hamster/widgets/activityentry.py", line 214, in complete_inline
    self.set_text("%s%s" % (self.filter, prefix))
UnicodeDecodeError: 'utf8' codec can't decode byte 0xd1 in position 0: unexpected end of data

Local variables in innermost frame:
i: 3
self: <ActivityEntry object at 0x7f79a5881910 (hamster+widgets+activityentry+ActivityEntry at 0x561b0afc61e0)>
labels: ['\xd1\x81\xd1\x82\xd0\xbe\xd1\x8f\xd0\xbd\xd0\xb8\xd0\xb5 \xd0\xbd\xd0\xb0 \xd0\xb3\xd0\xbe\xd0\xbb\xd0\xbe\xd0\xb2\xd0\xb5@\xd0\x95\xd0\xb6\xd0\xb5\xd0\xb4\xd0\xbd\xd0\xb5\xd0\xb2\xd0\xbd\xd0\xb0\xd1\x8f \xd1\x80\xd1\x83\xd1\x82\xd0\xb8\xd0\xbd\xd0\xb0', '\xd1\x81\xd1\x83\xd0\xbf\xd0\xb5\xd1\x80\xd1\x81\xd0\xb5\xd0\xba\xd1\x80\xd0\xb5\xd1\x82\xd0\xbd\xd1\x8b\xd0\xb9 \xd0\xbf\xd1\x80\xd0\xbe\xd0\xb5\xd0\xba\xd1\x82 \xd1\x85@\xd0\xa0\xd0\xb0\xd0\xb1\xd0\xbe\xd1\x82\xd0\xb0']
subject: '\xd1\x81'
label: '\xd1\x81\xd1\x83\xd0\xbf\xd0\xb5\xd1\x80\xd1\x81\xd0\xb5\xd0\xba\xd1\x80\xd0\xb5\xd1\x82\xd0\xbd\xd1\x8b\xd0\xb9 \xd0\xbf\xd1\x80\xd0\xbe\xd0\xb5\xd0\xba\xd1\x82 \xd1\x85@\xd0\xa0\xd0\xb0\xd0\xb1\xd0\xbe\xd1\x82\xd0\xb0'
prefix: '\xd1'
prefix_length: 1
letter_matching: False
model: <gtk.ListStore object at 0x7f79a5881d70 (GtkListStore at 0x561b0b278e90)>
row: <gtk.TreeModelRow object at 0x7f79a587fa08>
shortest: 57
first: '\xd1\x81\xd1\x82\xd0\xbe\xd1\x8f\xd0\xbd\xd0\xb8\xd0\xb5 \xd0\xbd\xd0\xb0 \xd0\xb3\xd0\xbe\xd0\xbb\xd0\xbe\xd0\xb2\xd0\xb5@\xd0\x95\xd0\xb6\xd0\xb5\xd0\xb4\xd0\xbd\xd0\xb5\xd0\xb2\xd0\xbd\xd0\xb0\xd1\x8f \xd1\x80\xd1\x83\xd1\x82\xd0\xb8\xd0\xbd\xd0\xb0'
Comment 1 mastaiza 2015-12-18 20:02:47 EST
Created attachment 1107558 [details]
File: backtrace
Comment 2 mastaiza 2015-12-18 20:02:49 EST
Created attachment 1107559 [details]
File: environ
Comment 3 Raphael Groner 2015-12-19 07:38:25 EST
That looks like an unice issue. What language settings do you use? Can you reproduce the crash, what did you do for it?
Comment 4 Raphael Groner 2015-12-19 07:38:44 EST
Typo: unicode issue *
Comment 5 mastaiza 2015-12-19 11:34:09 EST
I do not know how to play the fall. Using the Russian language
Comment 6 Raphael Groner 2015-12-21 16:13:17 EST
Please test my scratch build. I can update in F23 if this build works for you.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12273598
Comment 8 mastaiza 2015-12-21 18:40:21 EST
A new version of a koji I can not run
Comment 9 Raphael Groner 2015-12-22 02:40:16 EST
Hmm, there's a similiar issue also about unicode handling at upstream,
Python 2.7 and special language settings.
https://github.com/projecthamster/hamster/issues/141
Comment 10 Fedora Update System 2016-02-02 15:45:33 EST
hamster-time-tracker-2.0-0.1.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e5b4e5be06
Comment 11 Fedora Update System 2016-02-02 17:04:33 EST
hamster-time-tracker-2.0-0.2.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-01bd33e7e6
Comment 12 Fedora Update System 2016-02-03 18:26:05 EST
hamster-time-tracker-2.0-0.2.rc1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-01bd33e7e6
Comment 13 Fedora Update System 2016-02-12 07:21:38 EST
hamster-time-tracker-2.0-0.2.rc1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.