Bug 1293010 - beaker-transfer should not try to move logs for deleted jobs
beaker-transfer should not try to move logs for deleted jobs
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: general (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 22.1
: ---
Assigned To: matt jia
tools-bugs
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 21:37 EST by Dan Callaghan
Modified: 2016-01-31 23:30 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-31 23:30:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2015-12-18 21:37:10 EST
Once a job has been deleted, there is no point beaker-transfer trying to move the logs anymore because they will just be deleted on the next run of beaker-log-delete. It should just ignore recipes from deleted jobs.
Comment 2 matt jia 2015-12-20 23:40:24 EST
On Gerrit:

   http://gerrit.beaker-project.org/#/c/4552/
Comment 4 Dan Callaghan 2016-01-19 02:01:57 EST
The following patch will help with verifying the beaker-transfer-related bugs because it lets us see exactly which recipes beaker-transfer is moving and when:

http://gerrit.beaker-project.org/#/c/4601/2

Suggested steps to verify this bug:
1. Schedule a job with /distribution/reservesys
2. Wait for it to start running and produce some logs
3. While it's still running, Cancel and then immediately Delete the job (the idea here is to delete it *before* beaker-transfer notices that it's finished and tries to transfer it)

Expected results:
beaker-transfer should ignore deleted recipe, it should not try to transfer the logs.
Comment 6 Dan Callaghan 2016-01-31 23:30:47 EST
Beaker 22.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.