Bug 1293055 - Black screen after logout from LXQt
Black screen after logout from LXQt
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
24
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
:
Depends On:
Blocks: LXQt
  Show dependency treegraph
 
Reported: 2015-12-19 12:55 EST by Raphael Groner
Modified: 2016-03-18 11:19 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-18 11:19:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael Groner 2015-12-19 12:55:14 EST
Description of problem:
AFter logged out from LXQt Panel, I get a black screen with an alone mouse pointer. Workaround is to reboot or at least restart sddm.

Version-Release number of selected component (if applicable):
lxqt-panel-.10.0-1.fc23.x86_64       
lxqt-session-0.10.0-1.fc23.x86_64       
sddm-0.13.0-4.fc23.x86_64

How reproducible:
yes

Steps to Reproduce:
1. login to lxqt session
2. logout
3.

Actual results:
black screen

Expected results:
display manager should be shown with possibility to do another login

Additional info:
not sure what component to blame for sure. Maybe lxqt-session or sddm just crashes?
Comment 1 Raphael Groner 2016-01-07 17:42:19 EST
This is also reproducible when logout from a plasma5 session, using sddm here too. Now it's sddm to blame.
Comment 2 Pier Luigi Fiorini 2016-01-08 12:55:25 EST
Any relevant sddm log on the journal or any coredump from coredumpctl?
Comment 3 Rex Dieter 2016-01-08 13:03:10 EST
I've never seen sddm get stuck, but session end does sometimes take longer than expected (sometimes up to a minute or 2)
Comment 4 Fedora Blocker Bugs Application 2016-02-27 14:11:56 EST
Proposed as a Blocker for 24-beta by Fedora user raphgro using the blocker tracking app because:

 After logged out from LXQt Panel, I get a black screen with an alone mouse pointer. Workaround is to reboot or at least restart sddm.

This is also reproducible when logout from a plasma5 session, using sddm here too. Now it's sddm to blame.

 Rex Dieter 2016-01-08 19:03:10 CET
I've never seen sddm get stuck, but session end does sometimes take longer than expected (sometimes up to a minute or 2)
Comment 5 Stephen Gallagher 2016-02-29 10:55:32 EST
Just for the record, the appropriate criterion is: "Shutting down, logging out and rebooting must work using standard console commands and the mechanisms offered (if any) by all release-blocking desktops."

SDDM is installed by default on the KDE Live Image (which is blocking), so by that logic I'd say +1 blocker.
Comment 6 Pier Luigi Fiorini 2016-02-29 11:04:03 EST
An indication of system information when this black screen with a mouse cursor appears are welcome such as:

- what processes are running (output of ps auxw)
- logind sessions (loginctl list-sessions)
- session information for each session (loginctl show-session XX, loginctl session-status XX where XX is the session id)
- sddm log from journal
- ~/.xsession-errors
Comment 7 Raphael Groner 2016-02-29 11:05:34 EST
(In reply to Stephen Gallagher from comment #5)
…
> SDDM is installed by default on the KDE Live Image (which is blocking), so
> by that logic I'd say +1 blocker.

Right. Sorry about not being that clear.
Comment 8 Petr Schindler 2016-02-29 13:46:07 EST
Discussed at 2016-02-29 blocker review meeting: [1]. 

It was decided to delay the decision: This bug seems to be a blocker, but we want to have a few more people test with Plasma to be more sure of the breadth of impact before we vote on it

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2016-02-29/f24-blocker-review.2016-02-29-17.00.html
Comment 9 Kamil Páral 2016-03-07 13:07:43 EST
Discussed at today's blocker review meeting [1]. We decided to punt (delay decision) - we still don't have sufficient info to make a decision here. we will make a decision next week; if there is not sufficient indication by that time that this issue clearly affects a clean F24 KDE install, it will likely be rejected as a blocker

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-07/
Comment 11 Rex Dieter 2016-03-07 13:54:58 EST
fyi, plasma-workspace-5.5.5-3 builds include a back-ported fix for the possible dbus deadlock
Comment 12 Pier Luigi Fiorini 2016-03-07 18:48:37 EST
Just installed Fedora 24 with KDE on virt-manager.
I can reproduce the issue, Plasma logout doesn't lead back to the SDDM greeter.
However loginctl show-session 1 shows that the session is of class user rather than greeter, and Desktop=KDE.

ps auxwww shows a number of Plasma process like kwin_x11, krunner, xsettings-kde, plasmashell --shut-up etc...

I think that Plasma is to blame.
Comment 13 Pier Luigi Fiorini 2016-03-07 18:51:19 EST
loginctl session-status 1 shows sddm-helper (the process that starts the session) and all the Plasma processes.

The Plasma processes are not clearly killed on logout.
Comment 14 Raphael Groner 2016-03-08 03:24:58 EST
(In reply to Pier Luigi Fiorini from comment #12)
…
> I think that Plasma is to blame.

Please be aware that I originally tested with LXQt and it runs lxqt-session. There's no Plasma but LXQt is based on Qt5 as well and the user login happens via SDDM.
Comment 15 Pier Luigi Fiorini 2016-03-08 04:09:32 EST
Could you please check what's running when this happens?
Without session information is impossible to understand what's going on.
Comment 16 Raphael Groner 2016-03-08 04:11:58 EST
(In reply to Pier Luigi Fiorini from comment #15)
> Could you please check what's running when this happens?
> Without session information is impossible to understand what's going on.

I checked, there's no lxqt* related process running when the screen went black after user's clicked and confirmed to logout.
Comment 17 Pier Luigi Fiorini 2016-03-08 14:54:47 EST
Can't reproduce with LXQt.

* LXQt is now installed on the F24 virtual machine that was created yesterday with:

dnf install @lxqt

* Restarted SDDM to have the sessions list updated.
* Logged in on LXQt for the first time
* Logout
* SDDM greeter shows up after a couple of seconds
Comment 18 Fedora Update System 2016-03-12 17:44:11 EST
plasma-workspace-5.5.5-4.fc24 qt5-qtbase-5.6.0-0.41.rc.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-13bc6572ac
Comment 19 Kamil Páral 2016-03-14 13:01:07 EDT
Discussed at today's blocker review meeting [1]. Decided to split from this bug - the new bug is bug 1317618 and is AcceptedBlocker (Alpha) - per comment 12 it appears there is a bug preventing log out in a clean F24 KDE install from working, that bug is accepted as a blocker. We agree that a new report will be filed to separate the KDE case from the lxqt case and the new KDE bug will be the blocker.

This existing bug is kept for dealing with LXQt issue.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-14/

Please note that the update from comment 18 needs to be adjusted to mark fixing bug 1317618, thanks.
Comment 20 Fedora Update System 2016-03-15 14:49:59 EDT
plasma-workspace-5.5.5-4.fc24, qt5-qtbase-5.6.0-0.41.rc.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-13bc6572ac
Comment 21 Fedora Update System 2016-03-18 11:19:20 EDT
plasma-workspace-5.5.5-4.fc24, qt5-qtbase-5.6.0-0.41.rc.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.